aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/00-default.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-05-07 16:20:32 +0000
commitaa319d87f6e2a0608e485b2b30de70c56beb6b27 (patch)
treeaa3c35129007185c523ba8da15ce39f0c6085712 /target/linux/ar71xx/generic/profiles/00-default.mk
parent84407eb7cb30db11ee4c45e715f4712ecab3ab18 (diff)
downloadmaster-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.tar.gz
master-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.tar.bz2
master-187ad058-aa319d87f6e2a0608e485b2b30de70c56beb6b27.zip
ar71xx: add a new subtarget for nand based devices - saves around 44k on the lzma compressed generic kernel image
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21396 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/00-default.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/00-default.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/00-default.mk b/target/linux/ar71xx/generic/profiles/00-default.mk
new file mode 100644
index 0000000000..aa46f22c54
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/00-default.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default Profile (all drivers)
+ PACKAGES:=kmod-ath9k kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig vsc7385-ucode-ap83 vsc7385-ucode-pb44 vsc7395-ucode-ap83 vsc7395-ucode-pb44 wpad-mini
+endef
+
+define Profile/Default/Description
+ Default package set compatible with most boards.
+endef
+$(eval $(call Profile,Default))