aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
commitf6b18f60344692439bf1a942365b7b0946dae8c5 (patch)
tree4938c4707486438ac740dd55a96812c38da628cc /package
parent2190e2e3a3cecbd6a44a41a1723f3012832400e5 (diff)
downloadmaster-187ad058-f6b18f60344692439bf1a942365b7b0946dae8c5.tar.gz
master-187ad058-f6b18f60344692439bf1a942365b7b0946dae8c5.tar.bz2
master-187ad058-f6b18f60344692439bf1a942365b7b0946dae8c5.zip
Add a zyxel prestige profile for the adm5120eb target, build the hcd driver as a module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8317 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/usb.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 32a1457248..6d2545a310 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -90,6 +90,16 @@ define KernelPackage/usb-ohci/2.6
endef
$(eval $(call KernelPackage,usb-ohci))
+define KernelPackage/usb-adm5120
+ $(call usbdep,@LINUX_2_6_ADM5120||@LINUX_2_6_ADM5120EB)
+ TITLE:=Support for the ADM5120 HCD controller
+ DESCRIPTION:=Kernel support for the ADM5120 HCD USB controller
+ KCONFIG:=CONFIG_USB_ADM5120_HCD
+ FILES:=$(LINUX_DIR)/drivers/usb/host/adm5120-hcd.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,adm5120-hcd)
+endef
+$(eval $(call KernelPackage,usb-adm5120))
+
define KernelPackage/usb2
$(call usbdep,)
TITLE:=Support for USB2 controllers