aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
commitf6b18f60344692439bf1a942365b7b0946dae8c5 (patch)
tree4938c4707486438ac740dd55a96812c38da628cc
parent2190e2e3a3cecbd6a44a41a1723f3012832400e5 (diff)
downloadmaster-187ad058-f6b18f60344692439bf1a942365b7b0946dae8c5.tar.gz
master-187ad058-f6b18f60344692439bf1a942365b7b0946dae8c5.tar.bz2
master-187ad058-f6b18f60344692439bf1a942365b7b0946dae8c5.zip
Add a zyxel prestige profile for the adm5120eb target, build the hcd driver as a module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8317 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kernel/modules/usb.mk10
-rw-r--r--target/linux/adm5120eb-2.6/config/default2
-rw-r--r--target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk17
-rw-r--r--target/linux/adm5120eb-2.6/profiles/100-Texas.mk2
4 files changed, 29 insertions, 2 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 32a1457248..6d2545a310 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -90,6 +90,16 @@ define KernelPackage/usb-ohci/2.6
endef
$(eval $(call KernelPackage,usb-ohci))
+define KernelPackage/usb-adm5120
+ $(call usbdep,@LINUX_2_6_ADM5120||@LINUX_2_6_ADM5120EB)
+ TITLE:=Support for the ADM5120 HCD controller
+ DESCRIPTION:=Kernel support for the ADM5120 HCD USB controller
+ KCONFIG:=CONFIG_USB_ADM5120_HCD
+ FILES:=$(LINUX_DIR)/drivers/usb/host/adm5120-hcd.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,adm5120-hcd)
+endef
+$(eval $(call KernelPackage,usb-adm5120))
+
define KernelPackage/usb2
$(call usbdep,)
TITLE:=Support for USB2 controllers
diff --git a/target/linux/adm5120eb-2.6/config/default b/target/linux/adm5120eb-2.6/config/default
index 9b1daa2c41..05de7eee60 100644
--- a/target/linux/adm5120eb-2.6/config/default
+++ b/target/linux/adm5120eb-2.6/config/default
@@ -241,7 +241,7 @@ CONFIG_TRAD_SIGNALS=y
CONFIG_USB=y
# CONFIG_USBPCWATCHDOG is not set
# CONFIG_USB_ACM is not set
-CONFIG_USB_ADM5120_HCD=y
+CONFIG_USB_ADM5120_HCD=m
# CONFIG_USB_ATM is not set
# CONFIG_USB_CATC is not set
# CONFIG_USB_DEVICEFS is not set
diff --git a/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk b/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk
new file mode 100644
index 0000000000..b0741e84be
--- /dev/null
+++ b/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Zyxel
+ NAME:=Zyxel Prestige P-334/335/335-WT (default)
+ PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/Zyxel/Description
+ Package set compatible with the Zyxel prestige P-334/335/335-WT boards
+endef
+$(eval $(call Profile,Zyxel))
+
diff --git a/target/linux/adm5120eb-2.6/profiles/100-Texas.mk b/target/linux/adm5120eb-2.6/profiles/100-Texas.mk
index a9306ca702..727a0c0648 100644
--- a/target/linux/adm5120eb-2.6/profiles/100-Texas.mk
+++ b/target/linux/adm5120eb-2.6/profiles/100-Texas.mk
@@ -6,7 +6,7 @@
#
define Profile/Texas
- NAME:=Texas Instruments WiFi (default)
+ NAME:=Texas Instruments WiFi
PACKAGES:=kmod-acx
endef