aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-10-28 16:51:58 +0200
committerGitHub <noreply@github.com>2016-10-28 16:51:58 +0200
commit70ac526818a8f8ae03676dc6d0421fc022123ac3 (patch)
tree5ab420d0e8891bf659155281c2d2d9dd1dcb3cbe /package
parentce116bc6f997d8d6e6b976cacce5d4c60d705fc6 (diff)
parentc718b120e06d9b5c9784242291a7b0535cabda34 (diff)
downloadmaster-187ad058-70ac526818a8f8ae03676dc6d0421fc022123ac3.tar.gz
master-187ad058-70ac526818a8f8ae03676dc6d0421fc022123ac3.tar.bz2
master-187ad058-70ac526818a8f8ae03676dc6d0421fc022123ac3.zip
Merge pull request #131 from Ham22/tpm
add tpm support
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d680d326d3..9d01e3e0b3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -890,6 +890,25 @@ endef
$(eval $(call KernelPackage,random-omap))
+
+define KernelPackage/random-tpm
+ TITLE:= TPM hardware random support
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_HW_RANDOM_TPM=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/hw_random/tpm-rng.ko
+ AUTOLOAD:= $(call AutoProbe, tpm-rng)
+ DEPENDS:=+kmod-random-core kmod-tpm
+endef
+
+define KernelPackage/random-tpm/description
+ TPM backed random support.
+endef
+
+$(eval $(call KernelPackage,random-tpm))
+
+
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic Thermal sysfs driver
@@ -1075,3 +1094,38 @@ endef
$(eval $(call KernelPackage,virtio-mmio))
+define KernelPackage/tpm
+ TITLE:= TPM support
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_TCG_TPM=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm.ko
+ AUTOLOAD:= $(call AutoProbe, tpm)
+endef
+
+define KernelPackage/tpm/description
+ TPM support.
+endef
+
+$(eval $(call KernelPackage,tpm))
+
+
+define KernelPackage/tpm-i2c-infineon
+ TITLE:= TPM 1.2 infineon i2c driver
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_TCG_TIS_I2C_INFINEON=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm_i2c_infineon.ko
+ AUTOLOAD:= $(call AutoProbe, tpm_i2c_infineon)
+ DEPENDS:=+kmod-tpm kmod-i2c-core
+endef
+
+define KernelPackage/tpm-i2c-infineon/description
+ TPM 1.2 support for infineon i2c devices.
+endef
+
+$(eval $(call KernelPackage,tpm-i2c-infineon))
+
+