aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorIan Pozella <Ian.Pozella@imgtec.com>2016-09-01 11:24:11 +0100
committerIan Pozella <Ian.Pozella@imgtec.com>2016-10-15 13:16:26 +0100
commitc718b120e06d9b5c9784242291a7b0535cabda34 (patch)
tree43ac3f177dc22bba53b2ecaea2d372b6fa06faff /package
parent093184fcc4232f9b7e397e872d18772592c16cd5 (diff)
downloadmaster-187ad058-c718b120e06d9b5c9784242291a7b0535cabda34.tar.gz
master-187ad058-c718b120e06d9b5c9784242291a7b0535cabda34.tar.bz2
master-187ad058-c718b120e06d9b5c9784242291a7b0535cabda34.zip
kernel: add tpm support
This adds kernel support for tpm's providing: * kmod-tpm - tpm framework * kmod-tpm-i2c-infineon - infineon i2c 1.2 spec tpm * kmod-random-tpm - tpm backed rng Signed-off-by: Ian Pozella <Ian.Pozella@imgtec.com> Signed-off-by: Abhijit Mahajani <Abhijit.Mahajani@imgtec.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d680d326d3..9d01e3e0b3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -890,6 +890,25 @@ endef
$(eval $(call KernelPackage,random-omap))
+
+define KernelPackage/random-tpm
+ TITLE:= TPM hardware random support
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_HW_RANDOM_TPM=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/hw_random/tpm-rng.ko
+ AUTOLOAD:= $(call AutoProbe, tpm-rng)
+ DEPENDS:=+kmod-random-core kmod-tpm
+endef
+
+define KernelPackage/random-tpm/description
+ TPM backed random support.
+endef
+
+$(eval $(call KernelPackage,random-tpm))
+
+
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic Thermal sysfs driver
@@ -1075,3 +1094,38 @@ endef
$(eval $(call KernelPackage,virtio-mmio))
+define KernelPackage/tpm
+ TITLE:= TPM support
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_TCG_TPM=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm.ko
+ AUTOLOAD:= $(call AutoProbe, tpm)
+endef
+
+define KernelPackage/tpm/description
+ TPM support.
+endef
+
+$(eval $(call KernelPackage,tpm))
+
+
+define KernelPackage/tpm-i2c-infineon
+ TITLE:= TPM 1.2 infineon i2c driver
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_TCG_TIS_I2C_INFINEON=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm_i2c_infineon.ko
+ AUTOLOAD:= $(call AutoProbe, tpm_i2c_infineon)
+ DEPENDS:=+kmod-tpm kmod-i2c-core
+endef
+
+define KernelPackage/tpm-i2c-infineon/description
+ TPM 1.2 support for infineon i2c devices.
+endef
+
+$(eval $(call KernelPackage,tpm-i2c-infineon))
+
+