aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-14 23:36:45 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-14 23:36:45 +0000
commit70838d52bd2d3acd0194aad7acaf950cbe178210 (patch)
treedb194d5997d1aa1c2c2c0d746b9720e5b5168754 /package
parent5113b208dcb450eb11f23ffdd5621186ff368138 (diff)
downloadmaster-187ad058-70838d52bd2d3acd0194aad7acaf950cbe178210.tar.gz
master-187ad058-70838d52bd2d3acd0194aad7acaf950cbe178210.tar.bz2
master-187ad058-70838d52bd2d3acd0194aad7acaf950cbe178210.zip
package/kernel: kmod-hid: can't mix and match DEPENDS:= and $(call SetDepends/...)
Since the SetDepends macro does a: DEPENDS:= ... it can't be used after setting DEPENDS:= explicitly, or it will clobber the previous value. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27983 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index e67c41b72e..1e252e3746 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -252,12 +252,11 @@ $(eval $(call KernelPackage,gpio-nxp-74hc164))
define KernelPackage/hid
SUBMENU:=$(OTHER_MENU)
TITLE:=HID Devices
- DEPENDS:=+kmod-input-evdev
KCONFIG:=CONFIG_HID
FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
AUTOLOAD:=$(call AutoLoad,61,hid)
$(call SetDepends/hid)
- $(call AddDepends/input)
+ $(call AddDepends/input,+kmod-input-evdev)
endef
define KernelPackage/hid/description