aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-14 23:36:42 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-14 23:36:42 +0000
commit5113b208dcb450eb11f23ffdd5621186ff368138 (patch)
treee1745ca2f5b91f59bd7f9ca7e2e245e00c3af587 /package
parent3906d967645ce4fb6e4c99fd21170ea60691b7fe (diff)
downloadmaster-187ad058-5113b208dcb450eb11f23ffdd5621186ff368138.tar.gz
master-187ad058-5113b208dcb450eb11f23ffdd5621186ff368138.tar.bz2
master-187ad058-5113b208dcb450eb11f23ffdd5621186ff368138.zip
package/kernel: Fix AddDepends/SetDepends calls with make 3.82
The module definitions depend on 001-depends.mk being the first included, but make 3.82 does not sort the results of wildcards anymore, so do an explicit sort of the includes. Found by Philip Prindeville, thanks! git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27982 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index d3823547aa..13a305d7a1 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -45,5 +45,5 @@ endef
$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
-include ./modules/*.mk
+include $(sort $(wildcard ./modules/*.mk))
-include $(TOPDIR)/target/linux/*/modules.mk