aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMike Qin <Fengling.Qin@gmail.com>2016-07-15 22:16:44 +0800
committerMike Qin <Fengling.Qin@gmail.com>2016-07-15 22:16:59 +0800
commit138f0748e9ccb7a71dd4fbd4941f5d8ff6509366 (patch)
tree0f638d2aa17ec05c05a5dd607d3c06fbf1ede08e /package
parent2268ee8e1f16e7f888bf03c48011271a3ebae122 (diff)
downloadmaster-187ad058-138f0748e9ccb7a71dd4fbd4941f5d8ff6509366.tar.gz
master-187ad058-138f0748e9ccb7a71dd4fbd4941f5d8ff6509366.tar.bz2
master-187ad058-138f0748e9ccb7a71dd4fbd4941f5d8ff6509366.zip
packages: uboot-zynq: use dtc in kernel
Signed-off-by: Mike Qin <Fengling.Qin@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-zynq/Makefile3
-rw-r--r--package/boot/uboot-zynq/patches/001-use-dtc-in-kernel.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/package/boot/uboot-zynq/Makefile b/package/boot/uboot-zynq/Makefile
index 366bdc9775..48d2d6bd7d 100644
--- a/package/boot/uboot-zynq/Makefile
+++ b/package/boot/uboot-zynq/Makefile
@@ -84,7 +84,8 @@ endef
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
- CROSS_COMPILE=$(TARGET_CROSS)
+ CROSS_COMPILE=$(TARGET_CROSS) \
+ DTCDIR=$(LINUX_DIR)/scripts/dtc/
endef
define Package/uboot/install/default
diff --git a/package/boot/uboot-zynq/patches/001-use-dtc-in-kernel.patch b/package/boot/uboot-zynq/patches/001-use-dtc-in-kernel.patch
new file mode 100644
index 0000000000..553c99e02b
--- /dev/null
+++ b/package/boot/uboot-zynq/patches/001-use-dtc-in-kernel.patch
@@ -0,0 +1,13 @@
+Index: u-boot-2016.07/Makefile
+===================================================================
+--- u-boot-2016.07.orig/Makefile
++++ u-boot-2016.07/Makefile
+@@ -348,7 +348,7 @@ OBJDUMP = $(CROSS_COMPILE)objdump
+ AWK = awk
+ PERL = perl
+ PYTHON = python
+-DTC = dtc
++DTC = $(DTCDIR)dtc
+ CHECK = sparse
+
+ CHECKFLAGS := -D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ \