aboutsummaryrefslogtreecommitdiffstats
path: root/package/postgresql
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-07-10 15:06:24 +0000
committerNicolas Thill <nico@openwrt.org>2005-07-10 15:06:24 +0000
commit66d65bff91c99a32107debf2e5f80d4f858256ce (patch)
tree94159c00442dbc12466b607332e390a2379961f2 /package/postgresql
parentcbc2bb9f2090a50144e9278f1a0e5735784bc45c (diff)
downloadmaster-187ad058-66d65bff91c99a32107debf2e5f80d4f858256ce.tar.gz
master-187ad058-66d65bff91c99a32107debf2e5f80d4f858256ce.tar.bz2
master-187ad058-66d65bff91c99a32107debf2e5f80d4f858256ce.zip
Add some missing headers to STAGING_DIR, required to build php4 extension
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1399 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/postgresql')
-rw-r--r--package/postgresql/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/postgresql/Makefile b/package/postgresql/Makefile
index de021ba35b..1f37bb7527 100644
--- a/package/postgresql/Makefile
+++ b/package/postgresql/Makefile
@@ -95,6 +95,7 @@ $(IPKG_PGSQL_CLI):
$(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/include
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
@@ -106,6 +107,7 @@ install-dev: $(STAGING_DIR)/usr/lib/libpq.so
uninstall-dev:
rm -rf \
+ $(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
$(STAGING_DIR)/usr/include/postgres_ext.h \
$(STAGING_DIR)/usr/include/postgresql \