aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/postgresql/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/postgresql/Makefile b/package/postgresql/Makefile
index de021ba35b..1f37bb7527 100644
--- a/package/postgresql/Makefile
+++ b/package/postgresql/Makefile
@@ -95,6 +95,7 @@ $(IPKG_PGSQL_CLI):
$(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/include
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
@@ -106,6 +107,7 @@ install-dev: $(STAGING_DIR)/usr/lib/libpq.so
uninstall-dev:
rm -rf \
+ $(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
$(STAGING_DIR)/usr/include/postgres_ext.h \
$(STAGING_DIR)/usr/include/postgresql \