aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-10-23 10:25:26 +0000
committerSteven Barth <steven@midlink.org>2013-10-23 10:25:26 +0000
commita413fcd1bf8bc2ea4758b786055133dfb2158af7 (patch)
tree89647c21303b7595f26bc9204edb8f6bb6120042 /package/network/config/firewall
parent7002de6567623d624a8bf075cc6273240b3859e8 (diff)
downloadmaster-187ad058-a413fcd1bf8bc2ea4758b786055133dfb2158af7.tar.gz
master-187ad058-a413fcd1bf8bc2ea4758b786055133dfb2158af7.tar.bz2
master-187ad058-a413fcd1bf8bc2ea4758b786055133dfb2158af7.zip
firewall: Improve ubus support
* Use network.interface dump call instead of individual status calls to reduce overall netifd lookups and invokes to 1 per fw3 process. * Allow protocol handlers to assign a firewall zone for an interface in the data section to allow for dynamic firewall zone assignment. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38504 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/config/firewall')
-rw-r--r--package/network/config/firewall/Makefile4
-rw-r--r--package/network/config/firewall/files/firewall.hotplug2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 0d495117d4..ac4d16a388 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_VERSION:=2013-10-10
+PKG_VERSION:=2013-10-23
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fca5e39564e488b169c8c535dcf658649f81429e
+PKG_SOURCE_VERSION:=c25922c05ae594c4c35fa65f27fd21c3a033f4ec
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
diff --git a/package/network/config/firewall/files/firewall.hotplug b/package/network/config/firewall/files/firewall.hotplug
index 34f3afec9b..20a95d4363 100644
--- a/package/network/config/firewall/files/firewall.hotplug
+++ b/package/network/config/firewall/files/firewall.hotplug
@@ -1,6 +1,6 @@
#!/bin/sh
-[ "$ACTION" = ifup ] || exit 0
+[ "$ACTION" = ifup -o "$ACTION" = ifupdate ] || exit 0
/etc/init.d/firewall enabled || exit 0