aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/config/firewall/Makefile4
-rw-r--r--package/network/config/firewall/files/firewall.hotplug2
2 files changed, 3 insertions, 3 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 0d495117d4..ac4d16a388 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_VERSION:=2013-10-10
+PKG_VERSION:=2013-10-23
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fca5e39564e488b169c8c535dcf658649f81429e
+PKG_SOURCE_VERSION:=c25922c05ae594c4c35fa65f27fd21c3a033f4ec
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
diff --git a/package/network/config/firewall/files/firewall.hotplug b/package/network/config/firewall/files/firewall.hotplug
index 34f3afec9b..20a95d4363 100644
--- a/package/network/config/firewall/files/firewall.hotplug
+++ b/package/network/config/firewall/files/firewall.hotplug
@@ -1,6 +1,6 @@
#!/bin/sh
-[ "$ACTION" = ifup ] || exit 0
+[ "$ACTION" = ifup -o "$ACTION" = ifupdate ] || exit 0
/etc/init.d/firewall enabled || exit 0