aboutsummaryrefslogtreecommitdiffstats
path: root/package/kismet
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-16 10:18:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-16 10:18:01 +0000
commit02b89aa9c7edd73edac0ba401d30cea93143d538 (patch)
treef4deaf71694fe367f9d696525c69ff0d5b8debc8 /package/kismet
parent7df1d6160c5ae9151cb0a9bd25527d4a0e97fca9 (diff)
downloadmaster-187ad058-02b89aa9c7edd73edac0ba401d30cea93143d538.tar.gz
master-187ad058-02b89aa9c7edd73edac0ba401d30cea93143d538.tar.bz2
master-187ad058-02b89aa9c7edd73edac0ba401d30cea93143d538.zip
add some changes from whiterussian to head
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1455 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kismet')
-rw-r--r--package/kismet/Config.in2
-rw-r--r--package/kismet/Makefile6
-rw-r--r--package/kismet/ipkg/kismet.control11
3 files changed, 18 insertions, 1 deletions
diff --git a/package/kismet/Config.in b/package/kismet/Config.in
index 5650ad669a..d3708d78e1 100644
--- a/package/kismet/Config.in
+++ b/package/kismet/Config.in
@@ -1,7 +1,7 @@
menu "kismet - an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
config BR2_PACKAGE_KISMET
- bool
+ tristate
default n
depends BR2_PACKAGE_KISMET_CLIENT || BR2_PACKAGE_KISMET_DRONE || BR2_PACKAGE_KISMET_SERVER
diff --git a/package/kismet/Makefile b/package/kismet/Makefile
index 0f9c0cd26e..e1ee6c27cd 100644
--- a/package/kismet/Makefile
+++ b/package/kismet/Makefile
@@ -16,6 +16,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
+$(eval $(call PKG_template,KISMET,kismet,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,KISMET_CLIENT,kismet-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,KISMET_DRONE,kismet-drone,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,KISMET_SERVER,kismet-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -59,6 +60,11 @@ $(PKG_BUILD_DIR)/.built:
CPPFLAGS="-I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include -I$(LINUX_DIR)/include"
touch $@
+$(IPKG_KISMET):
+ install -d -m0755 $(IDIR_KISMET)/usr/bin/
+ cp -fpR $(PKG_BUILD_DIR)/scripts/kismet $(IDIR_KISMET)/usr/bin/
+ $(IPKG_BUILD) $(IDIR_KISMET) $(PACKAGE_DIR)
+
$(IPKG_KISMET_CLIENT):
install -d -m0755 $(IDIR_KISMET_CLIENT)/etc/kismet/
install -m0644 ./files/ap_manuf $(IDIR_KISMET_CLIENT)/etc/kismet/
diff --git a/package/kismet/ipkg/kismet.control b/package/kismet/ipkg/kismet.control
new file mode 100644
index 0000000000..dc0676f3d9
--- /dev/null
+++ b/package/kismet/ipkg/kismet.control
@@ -0,0 +1,11 @@
+Package: kismet
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: kismet-client, kismet-server
+Description: kismet
+ Kismet is an 802.11 layer2 wireless network detector,
+ sniffer, and intrusion detection system. Kismet will work with any
+ wireless card which supports raw monitoring (rfmon) mode, and can
+ sniff 802.11b, 802.11a, and 802.11g traffic.