aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-07-16 10:18:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-07-16 10:18:01 +0000
commit02b89aa9c7edd73edac0ba401d30cea93143d538 (patch)
treef4deaf71694fe367f9d696525c69ff0d5b8debc8
parent7df1d6160c5ae9151cb0a9bd25527d4a0e97fca9 (diff)
downloadmaster-187ad058-02b89aa9c7edd73edac0ba401d30cea93143d538.tar.gz
master-187ad058-02b89aa9c7edd73edac0ba401d30cea93143d538.tar.bz2
master-187ad058-02b89aa9c7edd73edac0ba401d30cea93143d538.zip
add some changes from whiterussian to head
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1455 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/kismet/Config.in2
-rw-r--r--package/kismet/Makefile6
-rw-r--r--package/kismet/ipkg/kismet.control11
-rwxr-xr-xtarget/default/target_skeleton/etc/init.d/S10boot14
-rwxr-xr-xtarget/default/target_skeleton/etc/init.d/S45firewall2
-rw-r--r--target/default/target_skeleton/etc/nvram.overrides24
-rw-r--r--target/linux/image/squashfs.mk2
7 files changed, 38 insertions, 23 deletions
diff --git a/package/kismet/Config.in b/package/kismet/Config.in
index 5650ad669a..d3708d78e1 100644
--- a/package/kismet/Config.in
+++ b/package/kismet/Config.in
@@ -1,7 +1,7 @@
menu "kismet - an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
config BR2_PACKAGE_KISMET
- bool
+ tristate
default n
depends BR2_PACKAGE_KISMET_CLIENT || BR2_PACKAGE_KISMET_DRONE || BR2_PACKAGE_KISMET_SERVER
diff --git a/package/kismet/Makefile b/package/kismet/Makefile
index 0f9c0cd26e..e1ee6c27cd 100644
--- a/package/kismet/Makefile
+++ b/package/kismet/Makefile
@@ -16,6 +16,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(TOPDIR)/package/rules.mk
+$(eval $(call PKG_template,KISMET,kismet,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,KISMET_CLIENT,kismet-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,KISMET_DRONE,kismet-drone,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,KISMET_SERVER,kismet-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -59,6 +60,11 @@ $(PKG_BUILD_DIR)/.built:
CPPFLAGS="-I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include -I$(LINUX_DIR)/include"
touch $@
+$(IPKG_KISMET):
+ install -d -m0755 $(IDIR_KISMET)/usr/bin/
+ cp -fpR $(PKG_BUILD_DIR)/scripts/kismet $(IDIR_KISMET)/usr/bin/
+ $(IPKG_BUILD) $(IDIR_KISMET) $(PACKAGE_DIR)
+
$(IPKG_KISMET_CLIENT):
install -d -m0755 $(IDIR_KISMET_CLIENT)/etc/kismet/
install -m0644 ./files/ap_manuf $(IDIR_KISMET_CLIENT)/etc/kismet/
diff --git a/package/kismet/ipkg/kismet.control b/package/kismet/ipkg/kismet.control
new file mode 100644
index 0000000000..dc0676f3d9
--- /dev/null
+++ b/package/kismet/ipkg/kismet.control
@@ -0,0 +1,11 @@
+Package: kismet
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: kismet-client, kismet-server
+Description: kismet
+ Kismet is an 802.11 layer2 wireless network detector,
+ sniffer, and intrusion detection system. Kismet will work with any
+ wireless card which supports raw monitoring (rfmon) mode, and can
+ sniff 802.11b, 802.11a, and 802.11g traffic.
diff --git a/target/default/target_skeleton/etc/init.d/S10boot b/target/default/target_skeleton/etc/init.d/S10boot
index f45eafb1e7..22096d5fbb 100755
--- a/target/default/target_skeleton/etc/init.d/S10boot
+++ b/target/default/target_skeleton/etc/init.d/S10boot
@@ -14,16 +14,14 @@ touch /var/log/lastlog
# set up the vlan*ports variables for the asus wl-500g deluxe
# if they don't already exist
-[ "$(nvram get boardtype)" = "bcm95365r" ] && \
-[ "$(nvram get boardnum)" = "45" ] && {
- [ -z "$(nvram get vlan0ports)" ] && \
- [ -z "$(nvram get vlan1ports)" ] && {
- nvram set vlan0ports="1 2 3 4 5*"
- nvram set vlan1ports="0 5"
- }
+[ "$(nvram get boardtype)" = "bcm95365r" \
+-a "$(nvram get boardnum)" = "45" \
+-a -z "$(nvram get vlan0ports)$(nvram get vlan1ports)" ] && {
+ nvram set vlan0ports="1 2 3 4 5*"
+ nvram set vlan1ports="0 5"
}
-cat /etc/modules /etc/modules.d/*|sed 's/^[^#]/insmod &/' 2>&-|ash
+sed 's/^[^#]/insmod &/' /etc/modules /etc/modules.d/* 2>&-|ash
ifconfig lo 127.0.0.1 up
ifconfig eth0 promisc
diff --git a/target/default/target_skeleton/etc/init.d/S45firewall b/target/default/target_skeleton/etc/init.d/S45firewall
index dc429f2725..8350ccbfef 100755
--- a/target/default/target_skeleton/etc/init.d/S45firewall
+++ b/target/default/target_skeleton/etc/init.d/S45firewall
@@ -26,7 +26,7 @@ iptables -t nat -N postrouting_rule
iptables -P INPUT DROP
iptables -A INPUT -m state --state INVALID -j DROP
iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
- iptables -A INPUT -p tcp --syn --tcp-option \! 2 -j DROP
+ iptables -A INPUT -p tcp --tcp-flags SYN SYN --tcp-option \! 2 -j DROP
#
# insert accept rule or to jump to new accept-check table here
diff --git a/target/default/target_skeleton/etc/nvram.overrides b/target/default/target_skeleton/etc/nvram.overrides
index 001a61329e..d457af48ee 100644
--- a/target/default/target_skeleton/etc/nvram.overrides
+++ b/target/default/target_skeleton/etc/nvram.overrides
@@ -20,8 +20,8 @@ remap () {
}
# hacks for wrt54g 1.x hardware
-[ "$(nvram get boardnum)" = "42" ] && \
-[ "$(nvram get boardtype)" = "bcm94710dev" ] && {
+[ "$(nvram get boardnum)" = "42" \
+-a "$(nvram get boardtype)" = "bcm94710dev" ] && {
debug "### wrt54g 1.x hack ###"
NVRAM_vlan1hwname="et0"
NVRAM_vlan2hwname="et0"
@@ -31,8 +31,8 @@ remap () {
}
# hacks for asus wl-500g deluxe
-[ "$(nvram get boardtype)" = "bcm95365r" ] && \
-[ "$(nvram get boardnum)" = "45" ] && {
+[ "$(nvram get boardtype)" = "bcm95365r" \
+-a "$(nvram get boardnum)" = "45" ] && {
debug "### wl-500g deluxe hacks ###"
NVRAM_vlan0hwname="et0"
NVRAM_vlan1hwname="et0"
@@ -42,32 +42,32 @@ remap () {
}
# hacks for asus wl-300g
-[ "$(nvram get productid)" = "WL300g" ] && {
+[ "$(nvram get productid)" = "WL300g" ] && {
debug "### wl-300g hacks ###"
NVRAM_lan_ifnames="eth0 eth2"
NVRAM_wan_ifname="none"
}
# hacks for wap54g hardware
-[ "$(nvram get boardnum)" = "2" ] || \
-[ "$(nvram get boardnum)" = "1024" ] && {
+[ "$(nvram get boardnum)" = "2" \
+-o "$(nvram get boardnum)" = "1024" ] && {
debug "### wap54g hack ###"
NVRAM_wan_ifname="none"
FAILSAFE_ifnames="eth0 eth1"
}
# hacks for buffalo wla2-g54l
-[ "$(nvram get boardnum)" = "00" ] && \
-[ "$(nvram get product_name)" = "Product_name" ] || \
-[ "$(nvram get product_name)" = "WLA2-G54L" ] && {
+[ "$(nvram get boardnum)" = "00" \
+-a "$(nvram get product_name)" = "Product_name" \
+-o "$(nvram get product_name)" = "WLA2-G54L" ] && {
debug "### wla2-g54l hacks ###"
NVRAM_wan_ifname="none"
NVRAM_lan_ifnames="vlan0"
}
# hack for asus wl-500g hardware
-[ "$(nvram get boardnum)" = "asusX" ] && \
-[ "$(nvram get boardtype)" = "bcm94710dev" ] && {
+[ "$(nvram get boardnum)" = "asusX" \
+-a "$(nvram get boardtype)" = "bcm94710dev" ] && {
FAILSAFE_ifnames="eth0 eth2"
}
diff --git a/target/linux/image/squashfs.mk b/target/linux/image/squashfs.mk
index 917a69ab8a..70a85b99ee 100644
--- a/target/linux/image/squashfs.mk
+++ b/target/linux/image/squashfs.mk
@@ -10,7 +10,7 @@ squashfs-clean:
$(KDIR)/root.squashfs:
@mkdir -p $(KDIR)/root/jffs
- $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -noappend -root-owned -le
+ $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le
squashfs-install: $(KDIR)/root.squashfs
$(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"