aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-24 15:36:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-24 15:36:08 +0000
commitefc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf (patch)
treef3362749d77044fd7bf9463b78edbce125210c96 /package/kernel/mac80211/Makefile
parentbd190241a017bdaa5da0c7c7c269c5347ac17dcd (diff)
downloadmaster-187ad058-efc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf.tar.gz
master-187ad058-efc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf.tar.bz2
master-187ad058-efc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf.zip
kernel: remove kmod-crypto-aes, AES crypto support is always built into the kernel
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46483 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/mac80211/Makefile')
-rw-r--r--package/kernel/mac80211/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 3394fbe353..40b08c08dd 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -78,7 +78,7 @@ endef
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack
- DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211 +hostapd-common
+ DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-cfg80211 +hostapd-common
KCONFIG:=\
CONFIG_AVERAGE=y
FILES:= $(PKG_BUILD_DIR)/net/mac80211/mac80211.ko
@@ -698,7 +698,7 @@ endef
define KernelPackage/net-libipw
$(call KernelPackage/mac80211/Default)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ipw2x00/libipw.ko
AUTOLOAD:=$(call AutoProbe,libipw)
endef