aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-24 15:36:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-24 15:36:08 +0000
commitefc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf (patch)
treef3362749d77044fd7bf9463b78edbce125210c96 /package
parentbd190241a017bdaa5da0c7c7c269c5347ac17dcd (diff)
downloadmaster-187ad058-efc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf.tar.gz
master-187ad058-efc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf.tar.bz2
master-187ad058-efc607b25a9ec371a8ca9f6bc94bd7a0118bb2bf.zip
kernel: remove kmod-crypto-aes, AES crypto support is always built into the kernel
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46483 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk24
-rw-r--r--package/kernel/mac80211/Makefile4
2 files changed, 5 insertions, 23 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 074eb23233..84e5147b6b 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -152,7 +152,7 @@ $(eval $(call KernelPackage,crypto-seqiv))
define KernelPackage/crypto-hw-talitos
TITLE:=Freescale integrated security engine (SEC) driver
- DEPENDS:=+kmod-crypto-aes +kmod-crypto-manager +kmod-crypto-hash +kmod-random-core +kmod-crypto-authenc
+ DEPENDS:=+kmod-crypto-manager +kmod-crypto-hash +kmod-random-core +kmod-crypto-authenc
KCONFIG:= \
CONFIG_CRYPTO_DEV_TALITOS
FILES:= \
@@ -166,7 +166,7 @@ $(eval $(call KernelPackage,crypto-hw-talitos))
define KernelPackage/crypto-hw-padlock
TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
- DEPENDS:=+kmod-crypto-aes +kmod-crypto-manager
+ DEPENDS:=+kmod-crypto-manager
KCONFIG:= \
CONFIG_CRYPTO_DEV_PADLOCK \
CONFIG_CRYPTO_DEV_PADLOCK_AES \
@@ -254,24 +254,6 @@ endef
$(eval $(call KernelPackage,crypto-hw-omap))
-define KernelPackage/crypto-aes
- TITLE:=AES cipher CryptoAPI module
- KCONFIG:=CONFIG_CRYPTO_AES CONFIG_CRYPTO_AES_586
- FILES:=$(LINUX_DIR)/crypto/aes_generic.ko
- AUTOLOAD:=$(call AutoLoad,09,aes_generic)
- $(call AddDepends/crypto)
-endef
-
-ifndef CONFIG_TARGET_x86_64
- define KernelPackage/crypto-aes/x86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko
- AUTOLOAD:=$(call AutoLoad,09,aes-i586)
- endef
-endif
-
-$(eval $(call KernelPackage,crypto-aes))
-
-
define KernelPackage/crypto-arc4
TITLE:=ARC4 (RC4) cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_ARC4
@@ -645,7 +627,7 @@ $(eval $(call KernelPackage,crypto-xts))
define KernelPackage/crypto-mv-cesa
TITLE:=Marvell crypto engine
- DEPENDS:=+kmod-crypto-manager +kmod-crypto-aes @TARGET_kirkwood||TARGET_orion||TARGET_mvebu
+ DEPENDS:=+kmod-crypto-manager @TARGET_kirkwood||TARGET_orion||TARGET_mvebu
KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 3394fbe353..40b08c08dd 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -78,7 +78,7 @@ endef
define KernelPackage/mac80211
$(call KernelPackage/mac80211/Default)
TITLE:=Linux 802.11 Wireless Networking Stack
- DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-cfg80211 +hostapd-common
+ DEPENDS+= +kmod-crypto-core +kmod-crypto-arc4 +kmod-cfg80211 +hostapd-common
KCONFIG:=\
CONFIG_AVERAGE=y
FILES:= $(PKG_BUILD_DIR)/net/mac80211/mac80211.ko
@@ -698,7 +698,7 @@ endef
define KernelPackage/net-libipw
$(call KernelPackage/mac80211/Default)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ipw2x00/libipw.ko
AUTOLOAD:=$(call AutoProbe,libipw)
endef