aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-21 06:59:41 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-21 06:59:41 +0000
commitdb089c61cceae7fdc9f7e203a6dff13f6e3265c5 (patch)
tree8f8c27f261c1e5b4ee7fe9aafa57924862ef6c03 /package/kernel/linux/modules/usb.mk
parent5a7023bdf6b315b401af5820b8c8910627172e78 (diff)
downloadmaster-187ad058-db089c61cceae7fdc9f7e203a6dff13f6e3265c5.tar.gz
master-187ad058-db089c61cceae7fdc9f7e203a6dff13f6e3265c5.tar.bz2
master-187ad058-db089c61cceae7fdc9f7e203a6dff13f6e3265c5.zip
kernel: remove module checks for 3.15/3.16/3.17
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45534 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk15
1 files changed, 4 insertions, 11 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 27f531d8ad..589894bcd1 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -18,8 +18,7 @@ define KernelPackage/usb-core
KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
FILES:= \
$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
- $(LINUX_DIR)/drivers/usb/usb-common.ko@lt3.16 \
- $(LINUX_DIR)/drivers/usb/common/usb-common.ko@ge3.16
+ $(LINUX_DIR)/drivers/usb/common/usb-common.ko
AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
$(call AddDepends/nls)
endef
@@ -1453,9 +1452,7 @@ define KernelPackage/usbip
KCONFIG:= \
CONFIG_USBIP_CORE \
CONFIG_USBIP_DEBUG=n
- FILES:= \
- $(LINUX_DIR)/drivers/staging/usbip/usbip-core.ko@lt3.17 \
- $(LINUX_DIR)/drivers/usb/usbip/usbip-core.ko@ge3.17
+ FILES:=$(LINUX_DIR)/drivers/usb/usbip/usbip-core.ko
AUTOLOAD:=$(call AutoProbe,usbip-core)
$(call AddDepends/usb)
endef
@@ -1467,9 +1464,7 @@ define KernelPackage/usbip-client
TITLE := USB-over-IP client driver
DEPENDS := +kmod-usbip
KCONFIG := CONFIG_USBIP_VHCI_HCD
- FILES := \
- $(LINUX_DIR)/drivers/staging/usbip/vhci-hcd.ko@lt3.17 \
- $(LINUX_DIR)/drivers/usb/usbip/vhci-hcd.ko@ge3.17
+ FILES :=$(LINUX_DIR)/drivers/usb/usbip/vhci-hcd.ko
AUTOLOAD := $(call AutoProbe,vhci-hcd)
$(call AddDepends/usb)
endef
@@ -1482,9 +1477,7 @@ $(call KernelPackage/usbip/Default)
TITLE := USB-over-IP host driver
DEPENDS := +kmod-usbip
KCONFIG := CONFIG_USBIP_HOST
- FILES := \
- $(LINUX_DIR)/drivers/staging/usbip/usbip-host.ko@lt3.17 \
- $(LINUX_DIR)/drivers/usb/usbip/usbip-host.ko@ge3.17
+ FILES :=$(LINUX_DIR)/drivers/usb/usbip/usbip-host.ko
AUTOLOAD := $(call AutoProbe,usbip-host)
$(call AddDepends/usb)
endef