aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-04-21 06:59:41 +0000
committerJohn Crispin <blogic@openwrt.org>2015-04-21 06:59:41 +0000
commitdb089c61cceae7fdc9f7e203a6dff13f6e3265c5 (patch)
tree8f8c27f261c1e5b4ee7fe9aafa57924862ef6c03 /package/kernel
parent5a7023bdf6b315b401af5820b8c8910627172e78 (diff)
downloadmaster-187ad058-db089c61cceae7fdc9f7e203a6dff13f6e3265c5.tar.gz
master-187ad058-db089c61cceae7fdc9f7e203a6dff13f6e3265c5.tar.bz2
master-187ad058-db089c61cceae7fdc9f7e203a6dff13f6e3265c5.zip
kernel: remove module checks for 3.15/3.16/3.17
Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45534 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk6
-rw-r--r--package/kernel/linux/modules/other.mk4
-rw-r--r--package/kernel/linux/modules/usb.mk15
-rw-r--r--package/kernel/linux/modules/video.mk16
4 files changed, 11 insertions, 30 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 21e98f3f8e..22c790d2ee 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -342,10 +342,8 @@ define KernelPackage/crypto-crc32c
TITLE:=CRC32c CRC module
DEPENDS:=+kmod-crypto-hash
KCONFIG:=CONFIG_CRYPTO_CRC32C
- FILES:= \
- $(LINUX_DIR)/crypto/crc32c.ko@lt3.15 \
- $(LINUX_DIR)/crypto/crc32c_generic.ko@ge3.15
- AUTOLOAD:=$(call AutoLoad,04,crc32c@lt3.15 crc32c_generic@ge3.15,1)
+ FILES:=$(LINUX_DIR)/crypto/crc32c_generic.ko
+ AUTOLOAD:=$(call AutoLoad,04,crc32c_generic,1)
$(call AddDepends/crypto)
endef
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 429b9eb885..082c74aa6c 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -256,9 +256,7 @@ define KernelPackage/iio-ad799x
KCONFIG:= \
CONFIG_AD799X_RING_BUFFER=y \
CONFIG_AD799X
- FILES:= \
- $(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko@lt3.16 \
- $(LINUX_DIR)/drivers/iio/adc/ad799x.ko@ge3.16
+ FILES:=$(LINUX_DIR)/drivers/iio/adc/ad799x.ko
AUTOLOAD:=$(call AutoLoad,56,ad799x)
endef
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 27f531d8ad..589894bcd1 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -18,8 +18,7 @@ define KernelPackage/usb-core
KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
FILES:= \
$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
- $(LINUX_DIR)/drivers/usb/usb-common.ko@lt3.16 \
- $(LINUX_DIR)/drivers/usb/common/usb-common.ko@ge3.16
+ $(LINUX_DIR)/drivers/usb/common/usb-common.ko
AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
$(call AddDepends/nls)
endef
@@ -1453,9 +1452,7 @@ define KernelPackage/usbip
KCONFIG:= \
CONFIG_USBIP_CORE \
CONFIG_USBIP_DEBUG=n
- FILES:= \
- $(LINUX_DIR)/drivers/staging/usbip/usbip-core.ko@lt3.17 \
- $(LINUX_DIR)/drivers/usb/usbip/usbip-core.ko@ge3.17
+ FILES:=$(LINUX_DIR)/drivers/usb/usbip/usbip-core.ko
AUTOLOAD:=$(call AutoProbe,usbip-core)
$(call AddDepends/usb)
endef
@@ -1467,9 +1464,7 @@ define KernelPackage/usbip-client
TITLE := USB-over-IP client driver
DEPENDS := +kmod-usbip
KCONFIG := CONFIG_USBIP_VHCI_HCD
- FILES := \
- $(LINUX_DIR)/drivers/staging/usbip/vhci-hcd.ko@lt3.17 \
- $(LINUX_DIR)/drivers/usb/usbip/vhci-hcd.ko@ge3.17
+ FILES :=$(LINUX_DIR)/drivers/usb/usbip/vhci-hcd.ko
AUTOLOAD := $(call AutoProbe,vhci-hcd)
$(call AddDepends/usb)
endef
@@ -1482,9 +1477,7 @@ $(call KernelPackage/usbip/Default)
TITLE := USB-over-IP host driver
DEPENDS := +kmod-usbip
KCONFIG := CONFIG_USBIP_HOST
- FILES := \
- $(LINUX_DIR)/drivers/staging/usbip/usbip-host.ko@lt3.17 \
- $(LINUX_DIR)/drivers/usb/usbip/usbip-host.ko@ge3.17
+ FILES :=$(LINUX_DIR)/drivers/usb/usbip/usbip-host.ko
AUTOLOAD := $(call AutoProbe,usbip-host)
$(call AddDepends/usb)
endef
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 7a7d80c534..3b06a143be 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -16,9 +16,7 @@ define KernelPackage/fb
TITLE:=Framebuffer support
DEPENDS:=@DISPLAY_SUPPORT
KCONFIG:=CONFIG_FB
- FILES:= \
- $(LINUX_DIR)/drivers/video/fb.ko@lt3.15 \
- $(LINUX_DIR)/drivers/video/fbdev/core/fb.ko@ge3.15
+ FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/fb.ko
AUTOLOAD:=$(call AutoLoad,06,fb)
endef
@@ -38,9 +36,7 @@ define KernelPackage/fb-cfb-fillrect
TITLE:=Framebuffer software rectangle filling support
DEPENDS:=+kmod-fb
KCONFIG:=CONFIG_FB_CFB_FILLRECT
- FILES:= \
- $(LINUX_DIR)/drivers/video/cfbfillrect.ko@lt3.15 \
- $(LINUX_DIR)/drivers/video/fbdev/core/cfbfillrect.ko@ge3.15
+ FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/cfbfillrect.ko
AUTOLOAD:=$(call AutoLoad,07,cfbfillrect)
endef
@@ -56,9 +52,7 @@ define KernelPackage/fb-cfb-copyarea
TITLE:=Framebuffer software copy area support
DEPENDS:=+kmod-fb
KCONFIG:=CONFIG_FB_CFB_COPYAREA
- FILES:= \
- $(LINUX_DIR)/drivers/video/cfbcopyarea.ko@lt3.15 \
- $(LINUX_DIR)/drivers/video/fbdev/core/cfbcopyarea.ko@ge3.15
+ FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/cfbcopyarea.ko
AUTOLOAD:=$(call AutoLoad,07,cfbcopyarea)
endef
@@ -73,9 +67,7 @@ define KernelPackage/fb-cfb-imgblt
TITLE:=Framebuffer software image blit support
DEPENDS:=+kmod-fb
KCONFIG:=CONFIG_FB_CFB_IMAGEBLIT
- FILES:= \
- $(LINUX_DIR)/drivers/video/cfbimgblt.ko@lt3.15 \
- $(LINUX_DIR)/drivers/video/fbdev/core/cfbimgblt.ko@ge3.15
+ FILES:=$(LINUX_DIR)/drivers/video/fbdev/core/cfbimgblt.ko
AUTOLOAD:=$(call AutoLoad,07,cfbimgblt)
endef