aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-07-04 22:33:00 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-07-04 22:33:00 +0000
commit8dcde6b2fd7f552cb9e4331919eb5f9a8cb6ac9b (patch)
treecdcf9b0f0788552800896fa4bde053135a694eb1 /package/kernel/linux/modules/other.mk
parent70b3fd189a9094c4feb0ce98dd0bf5c54d8cefa9 (diff)
downloadmaster-187ad058-8dcde6b2fd7f552cb9e4331919eb5f9a8cb6ac9b.tar.gz
master-187ad058-8dcde6b2fd7f552cb9e4331919eb5f9a8cb6ac9b.tar.bz2
master-187ad058-8dcde6b2fd7f552cb9e4331919eb5f9a8cb6ac9b.zip
kernel: add crypto-cmac
The bluetooth driver needs this new crypto lib in kernel 4.1 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46180 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d05b0d5758..473f063f55 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,6lowpan))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \