aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:19:31 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:19:31 +0000
commit51a736c6287eb29cc5150f06ce8fdf10b7441a1b (patch)
tree118b71cdb48ca028fca9fc82cb0b84a21fcd1e55 /package/kernel/linux/modules/other.mk
parentc976c9ee83991906f6eb16cec6dd6134bfbf225f (diff)
downloadmaster-187ad058-51a736c6287eb29cc5150f06ce8fdf10b7441a1b.tar.gz
master-187ad058-51a736c6287eb29cc5150f06ce8fdf10b7441a1b.tar.bz2
master-187ad058-51a736c6287eb29cc5150f06ce8fdf10b7441a1b.zip
package: kernel: update dependencies for 4.4
Update dependencies for linux 4.4 and mark as broken where source code needs updating. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47700 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk12
1 files changed, 8 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 93051e509a..9bb9dec2bc 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,6lowpan))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +LINUX_4_4:kmod-regmap
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -264,8 +264,10 @@ define KernelPackage/iio-core
CONFIG_IIO_TRIGGERED_BUFFER
FILES:= \
$(LINUX_DIR)/drivers/iio/industrialio.ko \
- $(if $(CONFIG_IIO_TRIGGERED_BUFFER),$(LINUX_DIR)/drivers/iio/industrialio-triggered-buffer.ko) \
- $(LINUX_DIR)/drivers/iio/kfifo_buf.ko
+ $(if $(CONFIG_IIO_TRIGGERED_BUFFER),$(LINUX_DIR)/drivers/iio/industrialio-triggered-buffer.ko@lt4.4) \
+ $(if $(CONFIG_IIO_TRIGGERED_BUFFER),$(LINUX_DIR)/drivers/iio/buffer/industrialio-triggered-buffer.ko@ge4.4) \
+ $(LINUX_DIR)/drivers/iio/kfifo_buf.ko@lt4.4 \
+ $(LINUX_DIR)/drivers/iio/buffer/kfifo_buf.ko@ge4.4
AUTOLOAD:=$(call AutoLoad,55,industrialio kfifo_buf industrialio-triggered-buffer)
endef
@@ -688,7 +690,9 @@ define KernelPackage/serial-8250
CONFIG_SERIAL_8250_SHARE_IRQ=y \
CONFIG_SERIAL_8250_DETECT_IRQ=n \
CONFIG_SERIAL_8250_RSA=n
- FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/tty/serial/8250/8250.ko \
+ $(LINUX_DIR)/drivers/tty/serial/8250/8250_base.ko@ge4.4
endef
define KernelPackage/serial-8250/description