aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/block.mk2
-rw-r--r--package/kernel/linux/modules/crypto.mk6
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
-rw-r--r--package/kernel/linux/modules/netfilter.mk2
-rw-r--r--package/kernel/linux/modules/other.mk12
-rw-r--r--package/kernel/linux/modules/usb.mk8
-rw-r--r--package/kernel/linux/modules/wpan.mk4
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mmc_over_gpio/Makefile2
9 files changed, 22 insertions, 18 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index c518a7251b..c83f98ddbd 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -377,7 +377,7 @@ $(eval $(call KernelPackage,md-raid10))
define KernelPackage/md-raid456
-$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor)
+$(call KernelPackage/md/Depends,+kmod-lib-raid6 +kmod-lib-xor +LINUX_4_4:kmod-lib-crc32c)
TITLE:=RAID Level 456 Driver
KCONFIG:= \
CONFIG_ASYNC_CORE \
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 9626b21fdb..062afe7168 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -27,7 +27,7 @@ define KernelPackage/crypto-aead
CONFIG_CRYPTO_AEAD2
FILES:=$(LINUX_DIR)/crypto/aead.ko
AUTOLOAD:=$(call AutoLoad,09,aead,1)
- $(call AddDepends/crypto)
+ $(call AddDepends/crypto, +LINUX_4_4:kmod-crypto-null)
endef
$(eval $(call KernelPackage,crypto-aead))
@@ -258,7 +258,7 @@ $(eval $(call KernelPackage,crypto-hw-omap))
define KernelPackage/crypto-authenc
TITLE:=Combined mode wrapper for IPsec
- DEPENDS:=+kmod-crypto-manager
+ DEPENDS:=+kmod-crypto-manager +LINUX_4_4:kmod-crypto-null
KCONFIG:=CONFIG_CRYPTO_AUTHENC
FILES:=$(LINUX_DIR)/crypto/authenc.ko
AUTOLOAD:=$(call AutoLoad,09,authenc)
@@ -625,7 +625,7 @@ define KernelPackage/crypto-null
KCONFIG:=CONFIG_CRYPTO_NULL
FILES:=$(LINUX_DIR)/crypto/crypto_null.ko
AUTOLOAD:=$(call AutoLoad,09,crypto_null)
- $(call AddDepends/crypto,+kmod-crypto-manager)
+ $(call AddDepends/crypto, +kmod-crypto-hash)
endef
$(eval $(call KernelPackage,crypto-null))
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index c649847aa6..ca0ff66172 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -83,7 +83,7 @@ define KernelPackage/hwmon-ina2xx
KCONFIG:=CONFIG_SENSORS_INA2XX
FILES:=$(LINUX_DIR)/drivers/hwmon/ina2xx.ko
AUTOLOAD:=$(call AutoProbe,ina2xx)
- $(call AddDepends/hwmon,+kmod-i2c-core)
+ $(call AddDepends/hwmon,+kmod-i2c-core +LINUX_4_4:kmod-regmap)
endef
define KernelPackage/hwmon-ina2xx/description
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index e21895d417..a0a19b23a9 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -473,7 +473,7 @@ $(eval $(call KernelPackage,ipt-tproxy))
define KernelPackage/ipt-tee
TITLE:=TEE support
- DEPENDS:=+kmod-ipt-conntrack
+ DEPENDS:=+kmod-ipt-conntrack @!LINUX_4_4
KCONFIG:= \
CONFIG_NETFILTER_XT_TARGET_TEE
FILES:= \
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 93051e509a..9bb9dec2bc 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -30,7 +30,7 @@ $(eval $(call KernelPackage,6lowpan))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +LINUX_4_4:kmod-regmap
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -264,8 +264,10 @@ define KernelPackage/iio-core
CONFIG_IIO_TRIGGERED_BUFFER
FILES:= \
$(LINUX_DIR)/drivers/iio/industrialio.ko \
- $(if $(CONFIG_IIO_TRIGGERED_BUFFER),$(LINUX_DIR)/drivers/iio/industrialio-triggered-buffer.ko) \
- $(LINUX_DIR)/drivers/iio/kfifo_buf.ko
+ $(if $(CONFIG_IIO_TRIGGERED_BUFFER),$(LINUX_DIR)/drivers/iio/industrialio-triggered-buffer.ko@lt4.4) \
+ $(if $(CONFIG_IIO_TRIGGERED_BUFFER),$(LINUX_DIR)/drivers/iio/buffer/industrialio-triggered-buffer.ko@ge4.4) \
+ $(LINUX_DIR)/drivers/iio/kfifo_buf.ko@lt4.4 \
+ $(LINUX_DIR)/drivers/iio/buffer/kfifo_buf.ko@ge4.4
AUTOLOAD:=$(call AutoLoad,55,industrialio kfifo_buf industrialio-triggered-buffer)
endef
@@ -688,7 +690,9 @@ define KernelPackage/serial-8250
CONFIG_SERIAL_8250_SHARE_IRQ=y \
CONFIG_SERIAL_8250_DETECT_IRQ=n \
CONFIG_SERIAL_8250_RSA=n
- FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/tty/serial/8250/8250.ko \
+ $(LINUX_DIR)/drivers/tty/serial/8250/8250_base.ko@ge4.4
endef
define KernelPackage/serial-8250/description
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 598ba4a97a..a238572d75 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -486,11 +486,9 @@ define KernelPackage/usb-dwc2
CONFIG_USB_DWC2_TRACK_MISSED_SOFS=n \
CONFIG_USB_DWC2_DEBUG_PERIODIC=n
FILES:= \
- $(LINUX_DIR)/drivers/usb/dwc2/dwc2.ko
- ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko),)
- FILES+=$(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko
- endif
- AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform,1)
+ $(LINUX_DIR)/drivers/usb/dwc2/dwc2.ko \
+ $(LINUX_DIR)/drivers/usb/dwc2/dwc2_platform.ko@lt4.3
+ AUTOLOAD:=$(call AutoLoad,54,dwc2 dwc2_platform@lt4.3,1)
$(call AddDepends/usb)
endef
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index 8cb1bfce2c..58fe8eb9d8 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -12,7 +12,8 @@ define KernelPackage/ieee802154
DEPENDS:=@!LINUX_3_18
KCONFIG:= \
CONFIG_IEEE802154 \
- CONFIG_IEEE802154_SOCKET=y
+ CONFIG_IEEE802154_SOCKET=y \
+ CONFIG_IEEE802154_NL802154_EXPERIMENTAL=n
FILES:= \
$(LINUX_DIR)/net/ieee802154/ieee802154.ko \
$(LINUX_DIR)/net/ieee802154/ieee802154_socket.ko@ge4.0
@@ -73,6 +74,7 @@ define KernelPackage/at86rf230
TITLE:=AT86RF230 transceiver driver
DEPENDS:=+kmod-mac802154 +kmod-regmap
KCONFIG:=CONFIG_IEEE802154_AT86RF230 \
+ CONFIG_IEEE802154_AT86RF230_DEBUGFS=n \
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
FILES:=$(LINUX_DIR)/drivers/net/ieee802154/at86rf230.ko
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 1dd1b84e7f..bbc7ee0497 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -78,7 +78,7 @@ endef
define KernelPackage/cfg80211
$(call KernelPackage/mac80211/Default)
TITLE:=cfg80211 - wireless configuration API
- DEPENDS+= +iw
+ DEPENDS+= +iw @!LINUX_4_4
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.ko \
$(PKG_BUILD_DIR)/net/wireless/cfg80211.ko
diff --git a/package/kernel/mmc_over_gpio/Makefile b/package/kernel/mmc_over_gpio/Makefile
index 69985a753d..ada293da10 100644
--- a/package/kernel/mmc_over_gpio/Makefile
+++ b/package/kernel/mmc_over_gpio/Makefile
@@ -15,7 +15,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/mmc-over-gpio
SUBMENU:=Other modules
- DEPENDS:=@GPIO_SUPPORT +kmod-mmc-spi +kmod-spi-gpio-old +kmod-fs-configfs
+ DEPENDS:=@GPIO_SUPPORT +kmod-mmc-spi +kmod-spi-gpio-old +kmod-fs-configfs @!LINUX_4_4
KCONFIG:=CONFIG_GPIOMMC
TITLE:=MMC/SD card over GPIO support
FILES:=$(LINUX_DIR)/drivers/mmc/host/gpiommc.ko