aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:33 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:33 +0000
commit0dab4848f48826a9604dd96edc8957c639d162af (patch)
tree099822c67220290d945ec92a6de1de5fb7378fba /package/kernel/linux/modules/lib.mk
parentbab75297b4f291e857e9b965cd7537d6f08c788d (diff)
downloadmaster-187ad058-0dab4848f48826a9604dd96edc8957c639d162af.tar.gz
master-187ad058-0dab4848f48826a9604dd96edc8957c639d162af.tar.bz2
master-187ad058-0dab4848f48826a9604dd96edc8957c639d162af.zip
kernel: move xor into its own package
xor.ko is needed by btrfs in 3.10+, so split it out into its own package. Make it hidden as it does not provide any functionality on its own. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37395 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 095edb1a58..39a928a02b 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -133,6 +133,22 @@ endef
$(eval $(call KernelPackage,lib-raid6))
+define KernelPackage/lib-xor
+ SUBMENU:=$(LIB_MENU)
+ TITLE:=XOR blocks algorithm support
+ HIDDEN:=1
+ KCONFIG:=CONFIG_XOR_BLOCKS
+ FILES:=$(LINUX_DIR)/crypto/xor.ko
+ AUTOLOAD:=$(call AutoLoad,20,xor,1)
+endef
+
+define KernelPackage/lib-xor/description
+ Kernel module for XOR blocks algorithms.
+endef
+
+$(eval $(call KernelPackage,lib-xor))
+
+
define KernelPackage/lib-textsearch
SUBMENU:=$(LIB_MENU)
TITLE:=Textsearch support