aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:31 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:31 +0000
commitbab75297b4f291e857e9b965cd7537d6f08c788d (patch)
treec852cb4d9192cac45dd27c9fe465f14290b1e267 /package/kernel/linux/modules/lib.mk
parentc82480a23d71e882244f1b343c94873240491b63 (diff)
downloadmaster-187ad058-bab75297b4f291e857e9b965cd7537d6f08c788d.tar.gz
master-187ad058-bab75297b4f291e857e9b965cd7537d6f08c788d.tar.bz2
master-187ad058-bab75297b4f291e857e9b965cd7537d6f08c788d.zip
kernel: split out lib-raid6
raid_pq.ko is needed by btrfs in 3.10+, so split it out into its own package. Make it hidden as it does not provide any functionality on its own. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37394 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 0411e93702..095edb1a58 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -117,6 +117,22 @@ endef
$(eval $(call KernelPackage,lib-lzo))
+define KernelPackage/lib-raid6
+ SUBMENU:=$(LIB_MENU)
+ TITLE:=RAID6 algorithm support
+ HIDDEN:=1
+ KCONFIG:=CONFIG_RAID6_PQ
+ FILES:=$(LINUX_DIR)/lib/raid6/raid6_pq.ko
+ AUTOLOAD:=$(call AutoLoad,20,raid6_pq,1)
+endef
+
+define KernelPackage/lib-raid6/description
+ Kernel module for RAID6 algorithms.
+endef
+
+$(eval $(call KernelPackage,lib-raid6))
+
+
define KernelPackage/lib-textsearch
SUBMENU:=$(LIB_MENU)
TITLE:=Textsearch support