aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-22 11:30:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-22 11:30:07 +0000
commitb52062356398d314ff3f8abe5dd0b42742248b1b (patch)
treec5adc3229cd55cac2064851efc9927ff093dbf06 /package/kernel/linux/modules/hwmon.mk
parent6c802b5fb67fd8f3228778aa8b6308fa244752d7 (diff)
downloadmaster-187ad058-b52062356398d314ff3f8abe5dd0b42742248b1b.tar.gz
master-187ad058-b52062356398d314ff3f8abe5dd0b42742248b1b.tar.bz2
master-187ad058-b52062356398d314ff3f8abe5dd0b42742248b1b.zip
linux: add kmod-hwmon-k10temp
This module is required to read the CPU core temperature sensors on the Alix APU board. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43027 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 301e06f6c2..5b7936a9f0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -288,3 +288,19 @@ define KernelPackage/hwmon-gpiofan/description
endef
$(eval $(call KernelPackage,hwmon-gpiofan))
+
+
+define KernelPackage/hwmon-k10temp
+ TITLE:=AMD Family 10h+ temperature sensor
+ KCONFIG:=CONFIG_SENSORS_K10TEMP
+ FILES:=$(LINUX_DIR)/drivers/hwmon/k10temp.ko
+ AUTOLOAD:=$(call AutoLoad,60,k10temp)
+ $(call AddDepends/hwmon,@PCI_SUPPORT @(x86||x86_64))
+endef
+
+define KernelPackage/hwmon-k10temp/description
+ Thermal sensor support for AMD 10h, 11h, 12h (Llano), 14h (Brazos),
+ 15h (Bulldozer/Trinity/Kaveri) and 16h (Kabini/Mullins) CPUs
+endef
+
+$(eval $(call KernelPackage,hwmon-k10temp))