aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 301e06f6c2..5b7936a9f0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -288,3 +288,19 @@ define KernelPackage/hwmon-gpiofan/description
endef
$(eval $(call KernelPackage,hwmon-gpiofan))
+
+
+define KernelPackage/hwmon-k10temp
+ TITLE:=AMD Family 10h+ temperature sensor
+ KCONFIG:=CONFIG_SENSORS_K10TEMP
+ FILES:=$(LINUX_DIR)/drivers/hwmon/k10temp.ko
+ AUTOLOAD:=$(call AutoLoad,60,k10temp)
+ $(call AddDepends/hwmon,@PCI_SUPPORT @(x86||x86_64))
+endef
+
+define KernelPackage/hwmon-k10temp/description
+ Thermal sensor support for AMD 10h, 11h, 12h (Llano), 14h (Brazos),
+ 15h (Bulldozer/Trinity/Kaveri) and 16h (Kabini/Mullins) CPUs
+endef
+
+$(eval $(call KernelPackage,hwmon-k10temp))