aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-08-09 17:18:10 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-08-09 17:18:10 +0000
commite65da8c824f744946da6a9493bf693459a185e25 (patch)
treeca0a7532623fa384a3c05041892d78c8fb0e0166 /package/kernel/linux/modules/crypto.mk
parented8f5404ea2ce14a0b7885920fa5d5f09290d956 (diff)
downloadmaster-187ad058-e65da8c824f744946da6a9493bf693459a185e25.tar.gz
master-187ad058-e65da8c824f744946da6a9493bf693459a185e25.tar.bz2
master-187ad058-e65da8c824f744946da6a9493bf693459a185e25.zip
kernel: crypto: fix depends in kmod-crypto-hmac
This module had two depends lines. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46576 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index d530b1471a..2e245e37a9 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -380,10 +380,9 @@ $(eval $(call KernelPackage,crypto-ecb))
define KernelPackage/crypto-hmac
TITLE:=HMAC digest CryptoAPI module
- DEPENDS:=+kmod-crypto-hash
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
KCONFIG:=CONFIG_CRYPTO_HMAC
FILES:=$(LINUX_DIR)/crypto/hmac.ko
- DEPENDS:=+kmod-crypto-manager
AUTOLOAD:=$(call AutoLoad,09,hmac)
$(call AddDepends/crypto)
endef