aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-08-09 17:17:51 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-08-09 17:17:51 +0000
commited8f5404ea2ce14a0b7885920fa5d5f09290d956 (patch)
tree4bfad25389f4ad8d41edc37de75570b82f8fbe36 /package/kernel/linux/modules/crypto.mk
parentaa9cbd1821f8eff2ecf0b3888c1087c2ae0485be (diff)
downloadmaster-187ad058-ed8f5404ea2ce14a0b7885920fa5d5f09290d956.tar.gz
master-187ad058-ed8f5404ea2ce14a0b7885920fa5d5f09290d956.tar.bz2
master-187ad058-ed8f5404ea2ce14a0b7885920fa5d5f09290d956.zip
kernel: crypto: fix module loading of cryptomgr.ko
There was no rule to load this module. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46575 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 7324d1a877..d530b1471a 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -66,6 +66,7 @@ define KernelPackage/crypto-manager
CONFIG_CRYPTO_MANAGER \
CONFIG_CRYPTO_MANAGER2
FILES:=$(LINUX_DIR)/crypto/cryptomgr.ko
+ AUTOLOAD:=$(call AutoLoad,09,cryptomgr,1)
$(call AddDepends/crypto)
endef