aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:14 +0000
commit96af999afd70c9b59dfd4864af708e9c7ef5fcd3 (patch)
tree4f02efb25db657f188060bcc32039bbbba23dca1 /package/kernel/linux/modules/crypto.mk
parent2d02649b87887051dc8dd90fcc5267ef8c4a60bb (diff)
downloadmaster-187ad058-96af999afd70c9b59dfd4864af708e9c7ef5fcd3.tar.gz
master-187ad058-96af999afd70c9b59dfd4864af708e9c7ef5fcd3.tar.bz2
master-187ad058-96af999afd70c9b59dfd4864af708e9c7ef5fcd3.zip
kernel/modules: add kmod-crypto-gcm
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43838 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 9d69cce9d5..73f36beaa1 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -400,6 +400,18 @@ endef
$(eval $(call KernelPackage,crypto-hmac))
+define KernelPackage/crypto-gcm
+ TITLE:=GCM/GMAC CryptoAPI module
+ DEPENDS:=+kmod-crypto-ctr +kmod-crypto-ghash +kmod-crypto-null
+ KCONFIG:=CONFIG_CRYPTO_GCM
+ FILES:=$(LINUX_DIR)/crypto/gcm.ko
+ AUTOLOAD:=$(call AutoLoad,09,gcm)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-gcm))
+
+
define KernelPackage/crypto-gf128
TITLE:=GF(2^128) multiplication functions CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_GF128MUL