aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:08 +0000
commit2d02649b87887051dc8dd90fcc5267ef8c4a60bb (patch)
tree8c3024f0fcb207bbf5489b2a5d937d796cddfd92 /package/kernel/linux/modules/crypto.mk
parent25a2bdc2f6d4a0152481b0321a2205256e8adf8a (diff)
downloadmaster-187ad058-2d02649b87887051dc8dd90fcc5267ef8c4a60bb.tar.gz
master-187ad058-2d02649b87887051dc8dd90fcc5267ef8c4a60bb.tar.bz2
master-187ad058-2d02649b87887051dc8dd90fcc5267ef8c4a60bb.zip
kernel/modules: add kmod-crypto-ghash
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index eec7934f16..9d69cce9d5 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -411,6 +411,18 @@ endef
$(eval $(call KernelPackage,crypto-gf128))
+define KernelPackage/crypto-ghash
+ TITLE:=GHASH digest CryptoAPI module
+ DEPENDS:=+kmod-crypto-gf128
+ KCONFIG:=CONFIG_CRYPTO_GHASH
+ FILES:=$(LINUX_DIR)/crypto/ghash-generic.ko
+ AUTOLOAD:=$(call AutoLoad,09,ghash-generic)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ghash))
+
+
define KernelPackage/crypto-md4
TITLE:=MD4 digest CryptoAPI module
DEPENDS:=+kmod-crypto-hash