aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:22 +0000
commitc4b2c7faf711c309f365d8c1803bd91014972047 (patch)
treebdc4fb56849c83531265e3b91137b338965ea843 /package/firmware
parentf0f775b9f616371dabecd9dcf2356874f1944275 (diff)
downloadmaster-187ad058-c4b2c7faf711c309f365d8c1803bd91014972047.tar.gz
master-187ad058-c4b2c7faf711c309f365d8c1803bd91014972047.tar.bz2
master-187ad058-c4b2c7faf711c309f365d8c1803bd91014972047.zip
ath10k-firmware: add qca99x0 firmware
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47295 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index bce0f80639..ac95543867 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -33,6 +33,15 @@ define Package/ath10k-firmware-qca988x
TITLE:=ath10k firmware for QCA988x devices
endef
+define Package/ath10k-firmware-qca99x0
+ SECTION:=kernel
+ CATEGORY:=Kernel modules
+ SUBMENU:=$(WMENU)
+ URL:=$(PKG_SOURCE_URL)
+ DEPENDS:=kmod-ath10k
+ TITLE:=ath10k firmware for QCA99x0 devices
+endef
+
define Build/Compile
endef
@@ -47,4 +56,15 @@ define Package/ath10k-firmware-qca988x/install
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
endef
+define Package/ath10k-firmware-qca99x0/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA99X0/hw2.0
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA99X0/hw2.0/boardData_AR900B_CUS239_5G_v2_001.bin \
+ $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/board.bin
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA99X0/hw2.0/firmware-5.bin_10.4.1.00030-1 \
+ $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/firmware-5.bin
+endef
+
$(eval $(call BuildPackage,ath10k-firmware-qca988x))
+$(eval $(call BuildPackage,ath10k-firmware-qca99x0))