aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:18 +0000
commitf0f775b9f616371dabecd9dcf2356874f1944275 (patch)
treea46b183fa9cd90eeb37deba1c20467b3ab181184 /package/firmware
parentcaae90c46bbd1b2824e3181a7545fc7306c8f622 (diff)
downloadmaster-187ad058-f0f775b9f616371dabecd9dcf2356874f1944275.tar.gz
master-187ad058-f0f775b9f616371dabecd9dcf2356874f1944275.tar.bz2
master-187ad058-f0f775b9f616371dabecd9dcf2356874f1944275.zip
ath10k: split out ath10k firmware into a separate source package and .ipk
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47294 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/ath10k-firmware/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
new file mode 100644
index 0000000000..bce0f80639
--- /dev/null
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ath10k-firmware
+PKG_SOURCE_VERSION:=7d14e337ad25c0ef3e78fc47eac336697ca612e8
+PKG_VERSION:=2014-10-28-$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=https://github.com/kvalo/ath10k-firmware.git
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+
+WMENU:=Wireless Drivers
+
+define Package/ath10k-firmware-qca988x
+ SECTION:=kernel
+ CATEGORY:=Kernel modules
+ SUBMENU:=$(WMENU)
+ URL:=$(PKG_SOURCE_URL)
+ DEFAULT:=PACKAGE_kmod-ath10k
+ DEPENDS:=kmod-ath10k
+ TITLE:=ath10k firmware for QCA988x devices
+endef
+
+define Build/Compile
+
+endef
+
+define Package/ath10k-firmware-qca988x/install
+ $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/ath10k/QCA988X/hw2.0/board.bin \
+ $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
+ $(INSTALL_DATA) \
+ $(PKG_BUILD_DIR)/QCA988X/10.2.4/firmware-5.bin_10.2.4.70-2 \
+ $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
+endef
+
+$(eval $(call BuildPackage,ath10k-firmware-qca988x))