aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:46 +0000
commit4b627b6f7dd1918b04197de823584072d04c0927 (patch)
treecba278933f9f28d9cfaf0987a058419b2336a9f2 /package/firmware
parentd43b63d859788cb83c6acad556982f84be5a3e0c (diff)
downloadmaster-187ad058-4b627b6f7dd1918b04197de823584072d04c0927.tar.gz
master-187ad058-4b627b6f7dd1918b04197de823584072d04c0927.tar.bz2
master-187ad058-4b627b6f7dd1918b04197de823584072d04c0927.zip
linux-firmware: remove duplication in package metadata
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48174 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/Makefile26
-rw-r--r--package/firmware/linux-firmware/realtek.mk19
2 files changed, 12 insertions, 33 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index 8b02bee2a0..e8b1b4d4d5 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -23,39 +23,33 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
include $(INCLUDE_DIR)/package.mk
-define Package/ibt-firmware
+define Package/firmware-default
SECTION:=firmware
CATEGORY:=Firmware
URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=Intel bluetooth firmware
+ TITLE:=$(1)
endef
+define Build/Compile
+
+endef
+
+Package/ibt-firmware = $(call Package/firmware-default,Intel bluetooth firmware)
define Package/ibt-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/intel
$(CP) \
$(PKG_BUILD_DIR)/intel/*.bseq \
$(1)/lib/firmware/intel
endef
+$(eval $(call BuildPackage,ibt-firmware))
-define Package/ar3k-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=ath3k firmware
-endef
-
+Package/ar3k-firmware = $(call Package/firmware-default,ath3k firmware)
define Package/ar3k-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/ar3k
$(CP) \
$(PKG_BUILD_DIR)/ar3k/*.dfu \
$(1)/lib/firmware/ar3k
endef
-
-define Build/Compile
-
-endef
+$(eval $(call BuildPackage,ar3k-firmware))
include $(wildcard ./*.mk)
-
-$(eval $(call BuildPackage,ar3k-firmware))
-$(eval $(call BuildPackage,ibt-firmware))
diff --git a/package/firmware/linux-firmware/realtek.mk b/package/firmware/linux-firmware/realtek.mk
index 9bf1cef3bf..5e3c34e6eb 100644
--- a/package/firmware/linux-firmware/realtek.mk
+++ b/package/firmware/linux-firmware/realtek.mk
@@ -1,32 +1,17 @@
-define Package/r8169-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=RealTek r8169 firmware
-endef
-
+Package/r8169-firmware = $(call Package/firmware-default,RealTek RTL8169 firmware)
define Package/r8169-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/rtl_nic
$(CP) \
$(PKG_BUILD_DIR)/rtl_nic/* \
$(1)/lib/firmware/rtl_nic
endef
-
$(eval $(call BuildPackage,r8169-firmware))
-
-define Package/r8188eu-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=RealTek r8188eu firmware
-endef
-
+Package/r8188eu-firmware = $(call Package/firmware-default,RealTek RTL8188EU firmware)
define Package/r8188eu-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware/rtlwifi
$(CP) \
$(PKG_BUILD_DIR)/rtlwifi/rtl8188eufw.bin \
$(1)/lib/firmware/rtlwifi
endef
-
$(eval $(call BuildPackage,r8188eu-firmware))