aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-10 16:35:40 +0000
commitd43b63d859788cb83c6acad556982f84be5a3e0c (patch)
treefe77cde5623f95a275f5a7d9bb830370ead5bbf4 /package/firmware
parenta21b53994d232f38bc1996e378526017288788d8 (diff)
downloadmaster-187ad058-d43b63d859788cb83c6acad556982f84be5a3e0c.tar.gz
master-187ad058-d43b63d859788cb83c6acad556982f84be5a3e0c.tar.bz2
master-187ad058-d43b63d859788cb83c6acad556982f84be5a3e0c.zip
linux-firmware: move realtek firmware packages to realtek.mk
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48173 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/firmware')
-rw-r--r--package/firmware/linux-firmware/Makefile32
-rw-r--r--package/firmware/linux-firmware/realtek.mk32
2 files changed, 34 insertions, 30 deletions
diff --git a/package/firmware/linux-firmware/Makefile b/package/firmware/linux-firmware/Makefile
index 6faa752290..8b02bee2a0 100644
--- a/package/firmware/linux-firmware/Makefile
+++ b/package/firmware/linux-firmware/Makefile
@@ -23,34 +23,6 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
include $(INCLUDE_DIR)/package.mk
-define Package/r8169-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=RealTek r8169 firmware
-endef
-
-define Package/r8169-firmware/install
- $(INSTALL_DIR) $(1)/lib/firmware/rtl_nic
- $(CP) \
- $(PKG_BUILD_DIR)/rtl_nic/* \
- $(1)/lib/firmware/rtl_nic
-endef
-
-define Package/r8188eu-firmware
- SECTION:=firmware
- CATEGORY:=Firmware
- URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
- TITLE:=RealTek r8188eu firmware
-endef
-
-define Package/r8188eu-firmware/install
- $(INSTALL_DIR) $(1)/lib/firmware/rtlwifi
- $(CP) \
- $(PKG_BUILD_DIR)/rtlwifi/rtl8188eufw.bin \
- $(1)/lib/firmware/rtlwifi
-endef
-
define Package/ibt-firmware
SECTION:=firmware
CATEGORY:=Firmware
@@ -83,7 +55,7 @@ define Build/Compile
endef
+include $(wildcard ./*.mk)
+
$(eval $(call BuildPackage,ar3k-firmware))
$(eval $(call BuildPackage,ibt-firmware))
-$(eval $(call BuildPackage,r8169-firmware))
-$(eval $(call BuildPackage,r8188eu-firmware))
diff --git a/package/firmware/linux-firmware/realtek.mk b/package/firmware/linux-firmware/realtek.mk
new file mode 100644
index 0000000000..9bf1cef3bf
--- /dev/null
+++ b/package/firmware/linux-firmware/realtek.mk
@@ -0,0 +1,32 @@
+define Package/r8169-firmware
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
+ TITLE:=RealTek r8169 firmware
+endef
+
+define Package/r8169-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/rtl_nic
+ $(CP) \
+ $(PKG_BUILD_DIR)/rtl_nic/* \
+ $(1)/lib/firmware/rtl_nic
+endef
+
+$(eval $(call BuildPackage,r8169-firmware))
+
+
+define Package/r8188eu-firmware
+ SECTION:=firmware
+ CATEGORY:=Firmware
+ URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
+ TITLE:=RealTek r8188eu firmware
+endef
+
+define Package/r8188eu-firmware/install
+ $(INSTALL_DIR) $(1)/lib/firmware/rtlwifi
+ $(CP) \
+ $(PKG_BUILD_DIR)/rtlwifi/rtl8188eufw.bin \
+ $(1)/lib/firmware/rtlwifi
+endef
+
+$(eval $(call BuildPackage,r8188eu-firmware))