aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-07-29 03:36:11 +0000
committerAndy Boyett <agb@openwrt.org>2008-07-29 03:36:11 +0000
commit26e3c2d39a60c10c7283c8e68b18315138bf9fa2 (patch)
tree8c624c8621f7e076ca853b9fc146691de88007ab /package/Makefile
parentfe34d714ae2cc448a71f61abb20f2fe6c138149c (diff)
downloadmaster-187ad058-26e3c2d39a60c10c7283c8e68b18315138bf9fa2.tar.gz
master-187ad058-26e3c2d39a60c10c7283c8e68b18315138bf9fa2.tar.bz2
master-187ad058-26e3c2d39a60c10c7283c8e68b18315138bf9fa2.zip
[ipkg] Generate gzipped package lists
- Can be used by changing the src line in /etc/ipkg.conf to src/gz - Cannot be used by busybox ipkg git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11981 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/Makefile b/package/Makefile
index a1f20b0b16..2a3354cf0a 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -45,7 +45,9 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
$(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
$(curdir)/index: FORCE
- @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+ @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+ gzip -9c Packages > Packages.gz \
+ )
$(curdir)/flags-install:= -j1