aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Makefile8
-rw-r--r--target/imagebuilder/files/Makefile6
2 files changed, 9 insertions, 5 deletions
diff --git a/package/Makefile b/package/Makefile
index a1f20b0b16..2a3354cf0a 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -45,7 +45,9 @@ $(curdir)/rootfs-prepare: $(TMP_DIR)/.build
$(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
$(curdir)/index: FORCE
- @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+ @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+ gzip -9c Packages > Packages.gz \
+ )
$(curdir)/flags-install:= -j1
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index aa5b97150d..27a6c94f9d 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -1,6 +1,6 @@
# Makefile for OpenWrt
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -112,7 +112,9 @@ endif
package_index: $(TOPDIR)/tmp/ipkg.conf FORCE
@echo
@echo Building package index...
- (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages) >/dev/null 2>/dev/null
+ (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+ gzip -9c Packages > Packages.gz \
+ ) >/dev/null 2>/dev/null
$(IPKG) update
package_install: FORCE