aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:12 +0000
commitdee598b99b23581a5eb29d2c79f7721e7d1dca8c (patch)
treed1c9db843dfb9857ac78c5b6ee08e31ea15ef4e1 /include
parent0e389d46a75122cf83d02040af1ceab6e92e7afb (diff)
downloadmaster-187ad058-dee598b99b23581a5eb29d2c79f7721e7d1dca8c.tar.gz
master-187ad058-dee598b99b23581a5eb29d2c79f7721e7d1dca8c.tar.bz2
master-187ad058-dee598b99b23581a5eb29d2c79f7721e7d1dca8c.zip
don't replace powerpc arch with ppc
'powerpc' is a valid arch for the LINUX_KARCH variable, but the build system unconditionally replaces LIUNUX_KARCH=powerpc with LINUX_KARCH=ppc. This change only does the replacement if LINUX_KARCH isn't set. This allows us to use the powerpc architecture. Signed-off-by: Jeremy Kerr <jk@ozlabs.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9405 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk15
1 files changed, 8 insertions, 7 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 7486057052..f9baeef0ac 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -51,13 +51,14 @@ endif
ifneq (,$(findstring uml,$(BOARD)))
LINUX_KARCH:=um
else
- LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
- -e 's/mipsel/mips/' \
- -e 's/mipseb/mips/' \
- -e 's/powerpc/ppc/' \
- -e 's/sh[234]/sh/' \
- -e 's/armeb/arm/' \
- )
+ ifeq (,$(LINUX_KARCH))
+ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ -e 's/mipsel/mips/' \
+ -e 's/mipseb/mips/' \
+ -e 's/sh[234]/sh/' \
+ -e 's/armeb/arm/' \
+ )
+ endif
endif