aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel.mk15
-rw-r--r--target/linux/amcc/Makefile1
-rw-r--r--target/linux/magicbox/Makefile1
3 files changed, 10 insertions, 7 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 7486057052..f9baeef0ac 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -51,13 +51,14 @@ endif
ifneq (,$(findstring uml,$(BOARD)))
LINUX_KARCH:=um
else
- LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
- -e 's/mipsel/mips/' \
- -e 's/mipseb/mips/' \
- -e 's/powerpc/ppc/' \
- -e 's/sh[234]/sh/' \
- -e 's/armeb/arm/' \
- )
+ ifeq (,$(LINUX_KARCH))
+ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ -e 's/mipsel/mips/' \
+ -e 's/mipseb/mips/' \
+ -e 's/sh[234]/sh/' \
+ -e 's/armeb/arm/' \
+ )
+ endif
endif
diff --git a/target/linux/amcc/Makefile b/target/linux/amcc/Makefile
index d582d81915..5e52d38c77 100644
--- a/target/linux/amcc/Makefile
+++ b/target/linux/amcc/Makefile
@@ -12,6 +12,7 @@ BOARDNAME:=AMCC Taishan
FEATURES:=jffs2
LINUX_VERSION:=2.6.21.5
+LINUX_KARCH:=ppc
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/magicbox/Makefile b/target/linux/magicbox/Makefile
index b130095624..15f035a82e 100644
--- a/target/linux/magicbox/Makefile
+++ b/target/linux/magicbox/Makefile
@@ -12,6 +12,7 @@ BOARDNAME:=Magicbox
FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.22.4
+LINUX_KARCH:=ppc
include $(INCLUDE_DIR)/target.mk