aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-02-29 20:12:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-02-29 20:12:25 +0000
commit6a47427d7c471bcd274a1e41f91a32845feec34a (patch)
treedd014f3d3833abf1b64d21ddb95d7d91bda60b04 /include
parent6d5d96c0ceb438d0b89ad145af8b6ac7b0c59dfe (diff)
downloadmaster-187ad058-6a47427d7c471bcd274a1e41f91a32845feec34a.tar.gz
master-187ad058-6a47427d7c471bcd274a1e41f91a32845feec34a.tar.bz2
master-187ad058-6a47427d7c471bcd274a1e41f91a32845feec34a.zip
buildroot: improve git submodule handling for packages
Move the `--recursive` switch from `git clone` to `git submodule` so that submodules are cloned for upstream branches where the PKG_SOURCE_VERSION commit-ish has a different .gitmodules configuration than the repository default. This is, for example, required when the master branch for a source package does not use submodules, but its topic branch for OpenWRT does. This changes the buildroot dependency from git-1.6.2 to git 1.7.12.2, which was released September 2012. Signed-off-by: Darik Horn <dajhorn@vanadac.com> Signed-off-by: Karl Palsson <karlp@tweak.net.au> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48830 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/download.mk5
-rw-r--r--include/prereq-build.mk4
2 files changed, 5 insertions, 4 deletions
diff --git a/include/download.mk b/include/download.mk
index 988542f95a..63af908114 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -90,8 +90,9 @@ define DownloadMethod/git
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- git clone $(URL) $(SUBDIR) --recursive && \
- (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \
+ git clone $(URL) $(SUBDIR) && \
+ (cd $(SUBDIR) && git checkout $(VERSION) && \
+ git submodule update --init --recursive) && \
echo "Packing checkout..." && \
rm -rf $(SUBDIR)/.git && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index bcb2103047..23a5b932ed 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -154,8 +154,8 @@ $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
$(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
svn --version | grep Subversion))
-$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.6.5, \
- git clone 2>&1 | grep -- --recursive))
+$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
+ git submodule update --help 2>&1 | grep -- --recursive))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))