aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
commitbbf13d61b7377b5114d9c716b7326f3f2bc468c1 (patch)
tree49c57d1eb3a67cf87f3072d933bda0faff33973d /include/image.mk
parente0d21348b5527b507648cd87898501eade36a94f (diff)
downloadmaster-187ad058-bbf13d61b7377b5114d9c716b7326f3f2bc468c1.tar.gz
master-187ad058-bbf13d61b7377b5114d9c716b7326f3f2bc468c1.tar.bz2
master-187ad058-bbf13d61b7377b5114d9c716b7326f3f2bc468c1.zip
image.mk: store the device name variable
Make the device name accessible for any build commands instead of forcing targets to define it themselves. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 583bc66157..5722231044 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -367,6 +367,7 @@ endef
define Device/Init
PROFILES := $(PROFILE)
+ DEVICE_NAME := $(1)
KERNEL:=
KERNEL_INITRAMFS = $$(KERNEL)
KERNEL_SIZE:=
@@ -391,7 +392,7 @@ define Device/ExportVar
endef
define Device/Export
- $(foreach var,$(DEVICE_VARS) KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
+ $(foreach var,$(DEVICE_VARS) DEVICE_NAME KERNEL KERNEL_INITRAMFS,$(call Device/ExportVar,$(1),$(var)))
$(1) : FILESYSTEM:=$(2)
endef