aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:51 +0000
commit13700f454c9a802728bf6bc78cf305b00af4b80b (patch)
tree6e9b0f6a449c85bf8f66bb738ad7efccf3069be2 /include/image.mk
parent31b0a25f6af527864b730ff9edd7ec31a34e7dfc (diff)
downloadmaster-187ad058-13700f454c9a802728bf6bc78cf305b00af4b80b.tar.gz
master-187ad058-13700f454c9a802728bf6bc78cf305b00af4b80b.tar.bz2
master-187ad058-13700f454c9a802728bf6bc78cf305b00af4b80b.zip
image: disable compile target within image builder
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index b8be838313..921d78d10d 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -359,7 +359,7 @@ endef
define Device/Check
_TARGET = $$(if $$(filter $(PROFILE),$$(PROFILES)),install,install-disabled)
- _COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
+ _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES))),compile,compile-disabled)
endef
ifndef IB