aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-11 09:17:39 +0000
commit31b0a25f6af527864b730ff9edd7ec31a34e7dfc (patch)
tree124baa072eb7fe777df9602d2f4c9c20d8139d7c /include/image.mk
parentfc59bdceefded42d118c190732c4a28386606b15 (diff)
downloadmaster-187ad058-31b0a25f6af527864b730ff9edd7ec31a34e7dfc.tar.gz
master-187ad058-31b0a25f6af527864b730ff9edd7ec31a34e7dfc.tar.bz2
master-187ad058-31b0a25f6af527864b730ff9edd7ec31a34e7dfc.zip
build: disable initramfs build within image builder
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45673 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 1b7fd2404a..b8be838313 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -362,6 +362,7 @@ define Device/Check
_COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
endef
+ifndef IB
define Device/Build/initramfs
$$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
@@ -373,6 +374,7 @@ define Device/Build/initramfs
@rm -f $$@
$$(call concat_cmd,$$(KERNEL_INITRAMFS))
endef
+endif
define Device/Build/check_size
@[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \