aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
commit3a437178dcc8337a5245223f22bb397bdb2fc54c (patch)
treee770d42073302bbe4740ae23c5d583d520cca1ec /include/host-build.mk
parentd318053bec071024030338b7032262f79e652e89 (diff)
downloadmaster-187ad058-3a437178dcc8337a5245223f22bb397bdb2fc54c.tar.gz
master-187ad058-3a437178dcc8337a5245223f22bb397bdb2fc54c.tar.bz2
master-187ad058-3a437178dcc8337a5245223f22bb397bdb2fc54c.zip
[buildroot] introduce a menuconfig option to turn off static linking of host utilities
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33154 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a8bc79ea67..40af5c87cc 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -66,7 +66,9 @@ HOST_CONFIGURE_ARGS = \
HOST_CONFIGURE_CMD = ./configure
ifneq ($(HOST_OS),Darwin)
- HOST_STATIC_LINKING = -static
+ ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+ HOST_STATIC_LINKING = -static
+ endif
endif
define Host/Configure/Default