aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-08-13 00:26:34 +0000
commit3a437178dcc8337a5245223f22bb397bdb2fc54c (patch)
treee770d42073302bbe4740ae23c5d583d520cca1ec
parentd318053bec071024030338b7032262f79e652e89 (diff)
downloadmaster-187ad058-3a437178dcc8337a5245223f22bb397bdb2fc54c.tar.gz
master-187ad058-3a437178dcc8337a5245223f22bb397bdb2fc54c.tar.bz2
master-187ad058-3a437178dcc8337a5245223f22bb397bdb2fc54c.zip
[buildroot] introduce a menuconfig option to turn off static linking of host utilities
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33154 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in7
-rw-r--r--include/host-build.mk4
2 files changed, 10 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index 0553712f76..e865777bee 100644
--- a/Config.in
+++ b/Config.in
@@ -153,6 +153,13 @@ menu "Global build settings"
When this option is enabled, packages are built with the full versions of iconv and GNU gettext
instead of the default OpenWrt stubs. If uClibc is used, it is also built with locale support.
+ config BUILD_STATIC_TOOLS
+ default y
+ bool "Attempt to link host utilities statically"
+ help
+ Linking host utilities like sed or firmware-utils statically increases the portability of the
+ generated ImageBuilder and SDK tarballs, however it may fail on some Linux distributions.
+
config SHADOW_PASSWORDS
bool
prompt "Enable shadow password support"
diff --git a/include/host-build.mk b/include/host-build.mk
index a8bc79ea67..40af5c87cc 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -66,7 +66,9 @@ HOST_CONFIGURE_ARGS = \
HOST_CONFIGURE_CMD = ./configure
ifneq ($(HOST_OS),Darwin)
- HOST_STATIC_LINKING = -static
+ ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
+ HOST_STATIC_LINKING = -static
+ endif
endif
define Host/Configure/Default