aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-08 01:19:52 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-08 01:19:52 +0000
commit5b6a0bc9483981647ed204ed4f95a5b565794b23 (patch)
tree73e59dd808c8ea6e4488f51b760d33704a5ab643 /include/autotools.mk
parentdae3c43cc3dcecd58e5ee957fb7f0b033abe6eb1 (diff)
downloadmaster-187ad058-5b6a0bc9483981647ed204ed4f95a5b565794b23.tar.gz
master-187ad058-5b6a0bc9483981647ed204ed4f95a5b565794b23.tar.bz2
master-187ad058-5b6a0bc9483981647ed204ed4f95a5b565794b23.zip
[include] autotools.mk: allow autogen.sh / autoreconf to fail (for now)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24320 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 3203604682..df5e85a5f5 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -25,10 +25,10 @@ endef
define autoreconf
(cd $(PKG_BUILD_DIR); \
if [ -x ./autogen.sh ]; then \
- ./autogen.sh; \
+ ./autogen.sh || true; \
elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
- $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
+ $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
fi \
);
endef