aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-08 01:15:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-08 01:15:38 +0000
commitdae3c43cc3dcecd58e5ee957fb7f0b033abe6eb1 (patch)
treea1b383cdd1c0d423a35c834c59d90a0b80ca2805 /include/autotools.mk
parent07d0739c17e1ca2004d6a4b08c5bb388fd0274a7 (diff)
downloadmaster-187ad058-dae3c43cc3dcecd58e5ee957fb7f0b033abe6eb1.tar.gz
master-187ad058-dae3c43cc3dcecd58e5ee957fb7f0b033abe6eb1.tar.bz2
master-187ad058-dae3c43cc3dcecd58e5ee957fb7f0b033abe6eb1.zip
[include] autotools.mk: if ./autogen.sh exists, call that. Call autoreconfig only if configure.in or configure.ac exists
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24319 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index a2d57d6971..3203604682 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -23,7 +23,14 @@ define libtool_remove_files
endef
define autoreconf
- (cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS));
+ (cd $(PKG_BUILD_DIR); \
+ if [ -x ./autogen.sh ]; then \
+ ./autogen.sh; \
+ elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+ $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+ $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
+ fi \
+ );
endef
Hooks/InstallDev/Post += libtool_remove_files