aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 03:07:05 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 03:07:05 +0200
commit8c658e15cc162c46c18dfc5b4b65be9ed03a9fb1 (patch)
tree1537ddf1dbbb24ff525613c8ba1e62304aca4a61
parent69ae4b5e66322bfd10adbba08d819ecfa3889108 (diff)
downloadmaster-187ad058-8c658e15cc162c46c18dfc5b4b65be9ed03a9fb1.tar.gz
master-187ad058-8c658e15cc162c46c18dfc5b4b65be9ed03a9fb1.tar.bz2
master-187ad058-8c658e15cc162c46c18dfc5b4b65be9ed03a9fb1.zip
include/host-build.mk: set Host/Exports for Host/Install step
Having a different PATH in Host/Install than in other steps like Host/Build is confusing and easily leads to mistakes. Setting all of Host/Exports makes host builds match target builds (Build/Install is part of $(STAMP_BUILT), which has Build/Exports set). Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--include/host-build.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 688f8d8442..72b32597d4 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -172,6 +172,7 @@ ifndef DUMP
$(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
touch $$@
+ $(call Host/Exports,$(HOST_STAMP_INSTALLED))
$(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
$(call Host/Install,$(HOST_BUILD_PREFIX))
$(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))