aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 03:07:05 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 03:07:05 +0200
commit69ae4b5e66322bfd10adbba08d819ecfa3889108 (patch)
tree895e0afb1614b0642769ce7e899c2804f086d878
parent7d7858f6f1b95f1f11e02bb0e6e386f4fa93bcf5 (diff)
downloadmaster-187ad058-69ae4b5e66322bfd10adbba08d819ecfa3889108.tar.gz
master-187ad058-69ae4b5e66322bfd10adbba08d819ecfa3889108.tar.bz2
master-187ad058-69ae4b5e66322bfd10adbba08d819ecfa3889108.zip
include/host-build.mk: fix ACLOCAL_INCLUDE
It seems the intention was to add both $(STAGING_DIR_HOST)/... and $(STAGING_DIR)/host/... instead of passing $(STAGING_DIR_HOST) twice. This makes the definition match HOST_CPPFLAGS and HOST_LDFLAGS. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--include/host-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 0b10c7cdf9..688f8d8442 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -133,7 +133,7 @@ define Download/default
endef
define Host/Exports/Default
- $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-* $(if $(IS_PACKAGE_BUILD),$$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-*)),-I $$(p))
+ $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-* $(if $(IS_PACKAGE_BUILD),$$(STAGING_DIR)/host/share/aclocal $$(STAGING_DIR)/host/share/aclocal-*)),-I $$(p))
$(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig