aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2005-09-10 17:21:57 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2005-09-10 17:21:57 +0000
commit7985bc86cb875e33a741b14d7068f73b992b02c1 (patch)
treece396e69503b070d294d31e232a0b6fefb66e42c
parentaec191316478c9f6bee471b219d852485fc9da6e (diff)
downloadmaster-187ad058-7985bc86cb875e33a741b14d7068f73b992b02c1.tar.gz
master-187ad058-7985bc86cb875e33a741b14d7068f73b992b02c1.tar.bz2
master-187ad058-7985bc86cb875e33a741b14d7068f73b992b02c1.zip
another KERNEL variable fix
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1889 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/package/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/package/Makefile b/target/linux/package/Makefile
index 4b8d068891..e55cc54d4b 100644
--- a/target/linux/package/Makefile
+++ b/target/linux/package/Makefile
@@ -8,12 +8,10 @@ package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
package-$(BR2_PACKAGE_KMOD_MADWIFI) += madwifi
package-y += openwrt
-ifeq ($(BOARD),brcm)
-ifeq ($(LINUX_VERSION),2.4.30)
+ifeq ($(BOARD)-$(KERNEL),brcm-2.4)
package-$(BR2_PACKAGE_KMOD_WLCOMPAT) += wlcompat
wlcompat-compile: openwrt-compile
endif
-endif
all: compile install
clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
@@ -21,6 +19,7 @@ compile: $(patsubst %,%-compile,$(package-y) $(package-m))
install: $(patsubst %,%-install,$(package-y))
MAKEOPTS:= BOARD="$(BOARD)" \
+ KERNEL="$(KERNEL)" \
IPKG="$(IPKG)" \
TARGET_DIR="$(TARGET_DIR)" \
BUILD_DIR="$(BUILD_DIR)" \