aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/package/Makefile')
-rw-r--r--target/linux/package/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/package/Makefile b/target/linux/package/Makefile
index 4b8d068891..e55cc54d4b 100644
--- a/target/linux/package/Makefile
+++ b/target/linux/package/Makefile
@@ -8,12 +8,10 @@ package-$(BR2_PACKAGE_KMOD_OPENSWAN) += openswan
package-$(BR2_PACKAGE_KMOD_MADWIFI) += madwifi
package-y += openwrt
-ifeq ($(BOARD),brcm)
-ifeq ($(LINUX_VERSION),2.4.30)
+ifeq ($(BOARD)-$(KERNEL),brcm-2.4)
package-$(BR2_PACKAGE_KMOD_WLCOMPAT) += wlcompat
wlcompat-compile: openwrt-compile
endif
-endif
all: compile install
clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
@@ -21,6 +19,7 @@ compile: $(patsubst %,%-compile,$(package-y) $(package-m))
install: $(patsubst %,%-install,$(package-y))
MAKEOPTS:= BOARD="$(BOARD)" \
+ KERNEL="$(KERNEL)" \
IPKG="$(IPKG)" \
TARGET_DIR="$(TARGET_DIR)" \
BUILD_DIR="$(BUILD_DIR)" \