aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 03:07:04 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2016-10-06 03:07:04 +0200
commit7d7858f6f1b95f1f11e02bb0e6e386f4fa93bcf5 (patch)
tree7d7a71f1c7639d39edcfc725cfea058df63e8b28
parent523c36dc04e4fd9558f58bcfb984f9159df7d9c4 (diff)
downloadmaster-187ad058-7d7858f6f1b95f1f11e02bb0e6e386f4fa93bcf5.tar.gz
master-187ad058-7d7858f6f1b95f1f11e02bb0e6e386f4fa93bcf5.tar.bz2
master-187ad058-7d7858f6f1b95f1f11e02bb0e6e386f4fa93bcf5.zip
include/host-build.mk: pass HOST_BUILD_PREFIX to Host/install
Makes it more consistent with package builds. Based-on-patch-by: Felix Fietkau <nbd@nbd.name> Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a494ceddf3..0b10c7cdf9 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -111,7 +111,7 @@ define Host/Install/Default
endef
define Host/Install
- $(call Host/Install/Default)
+ $(call Host/Install/Default,$(HOST_BUILD_PREFIX))
endef
@@ -173,7 +173,7 @@ ifndef DUMP
touch $$@
$(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
- $(call Host/Install)
+ $(call Host/Install,$(HOST_BUILD_PREFIX))
$(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
mkdir -p $$(shell dirname $$@)
touch $(HOST_STAMP_BUILT)